Hi there,

I'm trying to install version 3.0.1 of bugzilla. This is actually
supposed an upgrade to a version 2.20.1 but I'm pretty sure this isn't
an upgrade problem.

I've been following the instructions at
http://www.bugzilla.org/releases/3.0...#v30_upgrading

I fall over at the point of running checksetup.pl

Basically, it hangs with the error:

Deep recursion on subroutine "Image::Magick::AUTOLOAD" at
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Image/Magick.pm
line 42.

I will post the complete output of checksetup.pl at the bottom of this
e-mail. For ref, I'm on Fedora Core 5. ImageMagick which seems to be
implicated here, is reported by yum as follows:

ImageMagick.i386 6.2.5.4-4.2.1.fc5.7 installed
ImageMagick-perl.i386 6.2.5.4-4.2.1.fc5.7 installed

Anybody got any ideas?

Thanks,

Neil
--
Neil S Hamilton, Web Outreach

* This is Bugzilla 3.0.1 on perl 5.8.8
* Running on Linux 2.6.18-1.2257.fc5smp #1 SMP Fri Dec 15 16:33:51 EST 2006

Checking perl modules...
Checking for CGI (v2.93) ok: found v3.15
Checking for TimeDate (v2.21) ok: found v2.22
Checking for DBI (v1.41) ok: found v1.52
Checking for PathTools (v0.84) ok: found v3.24
Checking for Template-Toolkit (v2.12) ok: found v2.18
Checking for Email-Send (v2.00) not found
Checking for Email-MIME-Modifier (any) not found

Checking available perl DBD modules...
Checking for DBD-Pg (v1.45) not found
Checking for DBD-mysql (v2.9003) ok: found v3.0007

The following Perl modules are optional:
Checking for GD (v1.20) ok: found v2.35
Checking for Template-GD (any) not found
Checking for Chart (v1.0) ok: found v2.4.1
Checking for GDGraph (any) ok: found v1.44
Checking for GDTextUtil (any) ok: found v0.86
Checking for XML-Twig (any) not found
Checking for MIME-tools (v5.406) not found
Checking for libwww-perl (any) ok: found v2.033
Checking for PatchReader (v0.9.4) ok: found v0.9.5
Checking for PerlMagick (any) ok: found v6.3.2
Checking for perl-ldap (any) not found
Checking for SOAP-Lite (any) not found
Checking for HTML-Parser (v3.40) ok: found v3.51
Checking for HTML-Scrubber (any) not found
Checking for Email-MIME-Attachment-Stripper (any) not found
Checking for Email-Reply (any) not found
Checking for mod_perl (v1.999022) ok: found v2.000002
Checking for CGI (v3.11) ok: found v3.15
Checking for Apache-DBI (v0.96) not found

* NOTE: You must run any commands listed below as root.

************************************************** *********************
* REQUIRED MODULES *
************************************************** *********************
* Bugzilla requires you to install some Perl modules which are either *
* missing from your system, or the version on your system is too old. *
* *
* The latest versions of each module can be installed by running the *
* commands below. *
************************************************** *********************
COMMANDS:

/usr/bin/perl -MCPAN -e 'install Email::Send'
/usr/bin/perl -MCPAN -e 'install Email::MIME::Modifier'

************************************************** ********************
* OPTIONAL MODULES *
************************************************** ********************
* Certain Perl modules are not required by Bugzilla, but by *
* installing the latest version you gain access to additional *
* features. *
* *
* The optional modules you do not have installed are listed below, *
* with the name of the feature they enable. If you want to install *
* one of these modules, just run the appropriate command in the *
* "COMMANDS TO INSTALL" section. *
************************************************** ********************

************************************************** *********************
* MODULE NAME * ENABLES FEATURE(S) *
************************************************** *********************
* Template-GD * Graphical Reports *
* Email-MIME-Attachment-Stripper * Inbound Email *
* Email-Reply * Inbound Email *
* perl-ldap * LDAP Authentication *
* HTML-Scrubber * More HTML in Product/Group Descriptions *
* MIME-tools * Move Bugs Between Installations *
* XML-Twig * Move Bugs Between Installations *
* SOAP-Lite * XML-RPC Interface *
* Apache-DBI * mod_perl *
************************************************** *********************
COMMANDS TO INSTALL:

Template-GD: /usr/bin/perl -MCPAN -e 'install
Template::Plugin::GD::Image'
Email-MIME-Attachment-Stripper: /usr/bin/perl -MCPAN -e 'install
Email::MIME::Attachment::Stripper'
Email-Reply: /usr/bin/perl -MCPAN -e 'install Email::Reply'
perl-ldap: /usr/bin/perl -MCPAN -e 'install Net::LDAP'
HTML-Scrubber: /usr/bin/perl -MCPAN -e 'install HTML::Scrubber'
MIME-tools: /usr/bin/perl -MCPAN -e 'install MIME::Parser'
XML-Twig: /usr/bin/perl -MCPAN -e 'install XML::Twig'
SOAP-Lite: /usr/bin/perl -MCPAN -e 'install SOAP::Lite'
Apache-DBI: /usr/bin/perl -MCPAN -e 'install Apache:BI'
Deep recursion on subroutine "Image::Magick::AUTOLOAD" at
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Image/Magick.pm
line 42.