Field dependencies - Mozilla

This is a discussion on Field dependencies - Mozilla ; Hi all, Bugzilla n00b here. Does Bugzilla have the ability to support field dependencies? For example, when I'm at the Enter Bug page, I want my component field to be dependent on what version is select. Version 1.0 selected Components ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Field dependencies

  1. Field dependencies

    Hi all,

    Bugzilla n00b here. Does Bugzilla have the ability to support field
    dependencies? For example, when I'm at the Enter Bug page, I want my
    component field to be dependent on what version is select.

    Version 1.0 selected
    Components A, B, C are available

    Version 2.0 selected
    Components B, C, D are available

    Is this possible with Bugzilla?

    Thanks,
    -K


  2. Re: Field dependencies

    On Aug 24, 6:07 pm, Kris Bugbee wrote:
    > Hi all,
    >
    > Bugzilla n00b here. Does Bugzilla have the ability to support field
    > dependencies? For example, when I'm at the Enter Bug page, I want my
    > component field to be dependent on what version is select.
    >
    > Version 1.0 selected
    > Components A, B, C are available
    >
    > Version 2.0 selected
    > Components B, C, D are available
    >
    > Is this possible with Bugzilla?
    >
    > Thanks,
    > -K


    Anyone?


  3. Re: Field dependencies

    Kris,

    2007/8/25, Kris Bugbee :
    > Bugzilla n00b here. Does Bugzilla have the ability to support field
    > dependencies? For example, when I'm at the Enter Bug page, I want my
    > component field to be dependent on what version is select.
    >
    > Version 1.0 selected
    > Components A, B, C are available
    >
    > Version 2.0 selected
    > Components B, C, D are available


    this involves some hacking. I'd say your best bet is to look into how
    Bugzilla does a similar thing on the advanced search page (component,
    milestone and version lists are reduced when a product is selected),
    and start off from the ideas in use there.

    Regards
    Marc

  4. Re: Field dependencies

    Kris Bugbee wrote:
    > On Aug 24, 6:07 pm, Kris Bugbee wrote:
    >> Hi all,
    >>
    >> Bugzilla n00b here. Does Bugzilla have the ability to support field
    >> dependencies? For example, when I'm at the Enter Bug page, I want my
    >> component field to be dependent on what version is select.
    >>
    >> Version 1.0 selected
    >> Components A, B, C are available
    >>
    >> Version 2.0 selected
    >> Components B, C, D are available
    >>
    >> Is this possible with Bugzilla?
    >>
    >> Thanks,
    >> -K

    >
    > Anyone?
    >


    Hi Kris,

    Currently, versions and components are both product specific, so you
    can't have a list of components per version within the same product.
    You could use a different product for each version, or do some
    customization, but I'm guessing the customization would be
    non-trivial.

    Lisa

  5. Re: Field dependencies

    On Aug 28, 11:21 am, Lisa Henry wrote:
    > Kris Bugbee wrote:
    > > On Aug 24, 6:07 pm, Kris Bugbee wrote:
    > >> Hi all,

    >
    > >> Bugzilla n00b here. Does Bugzilla have the ability to support field
    > >> dependencies? For example, when I'm at the Enter Bug page, I want my
    > >> component field to be dependent on what version is select.

    >
    > >> Version 1.0 selected
    > >> Components A, B, C are available

    >
    > >> Version 2.0 selected
    > >> Components B, C, D are available

    >
    > >> Is this possible with Bugzilla?

    >
    > >> Thanks,
    > >> -K

    >
    > > Anyone?

    >
    > Hi Kris,
    >
    > Currently, versions and components are both product specific, so you
    > can't have a list of components per version within the same product.
    > You could use a different product for each version, or do some
    > customization, but I'm guessing the customization would be
    > non-trivial.
    >
    > Lisa- Hide quoted text -
    >
    > - Show quoted text -


    Thank you both for your reponses.


+ Reply to Thread