I'm updating Bugzilla from v2.18.1 to 3.0 on Red Hat Linux 3.2.3-54.
After following the process got 500 Internal Server Error.

checksetup returns this:

* This is Bugzilla 3.0 on perl 5.8.0
* Running on Linux 2.4.21-40.EL #1 Thu Feb 2 22:32:00 EST 2006

Checking perl modules...
Checking for CGI (v2.93) ok: found v3.29
Checking for TimeDate (v2.21) ok: found v2.22
Checking for DBI (v1.41) ok: found v1.48
Checking for PathTools (v0.84) ok: found v3.25
Checking for Template-Toolkit (v2.12) ok: found v2.14
Checking for Email-Send (v2.00) ok: found v2.185
Checking for Email-MIME-Modifier (any) ok: found v1.442

Checking available perl DBD modules...
Checking for DBD-Pg (v1.45) ok: found v1.49
Checking for DBD-mysql (v2.9003) ok: found v4.005

The following Perl modules are optional:
Checking for GD (v1.20) not found
Checking for Template-GD (any) not found
Checking for Chart (v1.0) not found
Checking for GDGraph (any) not found
Checking for GDTextUtil (any) not found
Checking for XML-Twig (any) ok: found v3.09
Checking for MIME-tools (v5.406) ok: found v5.420
Checking for libwww-perl (any) ok: found v2.001
Checking for PatchReader (v0.9.4) ok: found v0.9.5
Checking for PerlMagick (any) not found
Checking for perl-ldap (any) ok: found v0.34
Checking for SOAP-Lite (any) ok: found v0.69
Checking for HTML-Parser (v3.40) found v3.26
Checking for HTML-Scrubber (any) ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any) ok: found v1.313
Checking for Email-Reply (any) ok: found v1.202
Checking for mod_perl (v1.999022) not found
Checking for CGI (v3.11) ok: found v3.29
Checking for Apache-DBI (v0.96) ok: found v1.06

* NOTE: You must run any commands listed below as root.

************************************************** ********************
* OPTIONAL MODULES *
************************************************** ********************
* Certain Perl modules are not required by Bugzilla, but by *
* installing the latest version you gain access to additional *
* features. *
* *
* The optional modules you do not have installed are listed below, *
* with the name of the feature they enable. If you want to install *
* one of these modules, just run the appropriate command in the *
* "COMMANDS TO INSTALL" section. *
************************************************** ********************

************************************************** *********************
* MODULE NAME * ENABLES FEATURE(S) *
************************************************** *********************
* GDGraph * Graphical Reports *
* Template-GD * Graphical Reports *
* GDTextUtil * Graphical Reports *
* GD * Graphical Reports, New Charts, Old Charts *
* HTML-Parser * More HTML in Product/Group Descriptions *
* Chart * New Charts, Old Charts *
* PerlMagick * Optionally Convert BMP Attachments to PNGs *
* mod_perl * mod_perl *
************************************************** *********************
COMMANDS TO INSTALL:

GDGraph: /usr/bin/perl -MCPAN -e 'install GD::Graph'
Template-GD: /usr/bin/perl -MCPAN -e 'install
Template::Plugin::GD::Image'
GDTextUtil: /usr/bin/perl -MCPAN -e 'install GD::Text'
GD: /usr/bin/perl -MCPAN -e 'install GD'
HTML-Parser: /usr/bin/perl -MCPAN -e 'install HTML::Parser'
Chart: /usr/bin/perl -MCPAN -e 'install Chart::Base'
PerlMagick: /usr/bin/perl -MCPAN -e 'install Image::Magick'
mod_perl: /usr/bin/perl -MCPAN -e 'install mod_perl2'
Reading ./localconfig...
Checking for DBD-mysql (v2.9003) ok: found v4.005
/usr/bin/perl: relocation error:
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/my
sql.so: undefined symbol: mysql_server_init

Relating logging

mysqld.log:
===========

070820 11:51:05 mysqld started
070820 11:51:05 InnoDB: Out of memory in additional memory pool.
InnoDB: InnoDB will start allocating memory from the OS.
InnoDB: You may get better performance if you configure a bigger
InnoDB: value in the MySQL my.cnf file for
InnoDB: innodb_additional_mem_pool_size.
070820 11:51:05 InnoDB: Started
/usr/libexec/mysqld: ready for connections

error.log:
==========

[Mon Aug 20 11:52:27 2007] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Mon Aug 20 11:52:27 2007] [notice] Digest: generating secret for digest
authentication ...
[Mon Aug 20 11:52:27 2007] [notice] Digest: done
[Mon Aug 20 11:52:28 2007] [notice] Apache/2.0.46 (Red Hat) configured
-- resuming normal operations

[Mon Aug 20 11:53:35 2007] [error] [client 172.18.10.172] Use of
uninitialized value in concatenation (.) or string at Bugzilla/Auth.pm
line 44.
[Mon Aug 20 11:53:35 2007] [error] [client 172.18.10.172] Pseudo-hashes
are deprecated at Bugzilla/Auth/Login/Stack.pm line 34.
[Mon Aug 20 11:53:35 2007] [error] [client 172.18.10.172] Can't locate
Bugzilla/Auth/Login/.pm in @INC (@INC contains: .
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at
Bugzilla/Auth/Login/Stack.pm line 36.
[Mon Aug 20 11:53:35 2007] [error] [client 172.18.10.172] Premature end
of script headers: index.cgi


Any suggestions will be greatly appreciated
-Mark



************************************************** *************
Confidentiality Note: This e-mail is intended only for the person or
entity to which it is addressed and may contain information that is
privileged, confidential or otherwise protected from disclosure.
Dissemination, distribution or copying of this e-mail or the information
herein by anyone other than the intended recipient, or an employee or
agent responsible for delivering the message to the intended recipient,
is prohibited. If you have received this e-mail in error, please call
the Help Desk of Harco Laboratories, Inc. at 203-483-3700 and destroy the
original message and all copies.
************************************************** *************