bugzilla 3 under iis 5.1 - Mozilla

This is a discussion on bugzilla 3 under iis 5.1 - Mozilla ; Hello, I have installed bugzilla 3 under iis 5.1 on a windows xp professional box and need a little help fixing an issue. I am getting the famous 405 error raised from iis as in: HTTP 405 - Resource not ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: bugzilla 3 under iis 5.1

  1. bugzilla 3 under iis 5.1

    Hello,

    I have installed bugzilla 3 under iis 5.1 on a windows xp professional box and need a little help fixing an issue.

    I am getting the famous 405 error raised from iis as in:

    HTTP 405 - Resource not allowed
    Internet Information Services


    when trying to log into bugzilla.

    I have googled for several days on this issue to try to find the work around and have not yet found it.

    My setup is as follows:

    installed bugzilla-3.0.tar.gz
    installed ActivePerl-5.8.8.820-MSWin32-x86-274739.msi
    installed mysql-essential-5.0.45-win32.msi
    bugzilla is installed to c:\bugzilla
    active perl is installed to c:\perl
    mysql is installed to c:\mysql


    checksetup.pl passes fine and the bugzilla database is created.

    The bugzilla index.cgi page loads fine, I click log in, type in my email/password and when I try to log in the 405 error is raised by iis. I have read up that it is from something in the http headers that iis is not liking and thus causing this error.

    In the properties of the website in iis I have set the verbs option to "limit to" and have these set: GET,HEAD,POST,TRACE

    However, I have yet to fix the 405 error.


    Has anyone got this to work running iis and bugzilla 3? If so, can you explain what you had to do to get it to work and get past the 405 error raised by iis?


    thanks!


    Regards,
    Justin

  2. Re: bugzilla 3 under iis 5.1

    On 22 , 16:46, "Justin Daubenmire" wrote:
    > Hello,
    >
    > I have installed bugzilla 3 under iis 5.1 on a windows xp professional box and need a little help fixing an issue.
    >
    > I am getting the famous 405 error raised from iis as in:
    >
    > HTTP 405 - Resource not allowed
    > Internet Information Services
    >
    > when trying to log into bugzilla.
    > ...


    I've got almost exactly the same error, but with Bugzilla 2.22.2.
    However, it appeared only when I tried to log in from default page
    (http://localhost/bugzilla/), when I specified full starting address
    (http://localhost/bugzilla/index.cgi), it worked fine. So I created
    simple page that contained only redirect to index.cgi, and pointed to
    it as default page.



  3. Re: bugzilla 3 under iis 5.1


    wrote in message
    news:1186739398.406946.130410@x35g2000prf.googlegr oups.com...

    > I've got almost exactly the same error, but with Bugzilla 2.22.2.
    > However, it appeared only when I tried to log in from default page
    > (http://localhost/bugzilla/), when I specified full starting address
    > (http://localhost/bugzilla/index.cgi), it worked fine. So I created
    > simple page that contained only redirect to index.cgi, and pointed to
    > it as default page.


    Adding index.cgi to Documents > Enable Default Document in IIS Manager
    should also solve this.


+ Reply to Thread