Re: Installation problem after perl checksetup.pl - Mozilla

This is a discussion on Re: Installation problem after perl checksetup.pl - Mozilla ; > > Hello all, > > I am trying to install bugzilla locally here in a red hat ws 4 machine but > I am having the following problem: > > ---------------------- > [root@rodrigo bugzilla-2.20]# perl checksetup.pl > > Checking ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Re: Installation problem after perl checksetup.pl

  1. Re: Installation problem after perl checksetup.pl

    >
    > Hello all,
    >
    > I am trying to install bugzilla locally here in a red hat ws 4 machine but
    > I am having the following problem:
    >
    > ----------------------
    > [root@rodrigo bugzilla-2.20]# perl checksetup.pl
    >
    > Checking perl modules ...
    > Checking for AppConfig (v1.52) ok: found v1.56
    > Checking for CGI (v2.93) ok: found v3.05
    > Checking for Data:umper (any) ok: found v2.121
    > Checking for Date::Format (v2.21) ok: found v2.22
    > Checking for DBI (v1.38) ok: found v1.40
    > Checking for File::Spec (v0.84) ok: found v0.87
    > Checking for File::Temp (any) ok: found v0.14
    > Checking for Template (v2.08) ok: found v2.14
    > Checking for Text::Wrap (v2001.0131) ok: found v2001.09292
    > Checking for Mail::Mailer (v1.65) ok: found v1.73
    > Checking for Storable (any) ok: found v2.13
    >
    > The following Perl modules are optional:
    > Checking for GD (v1.20) ok: found v2.30
    > Checking for Chart::Base (v1.0) ok: found v2.4.1
    > Checking for XML::Parser (any) ok: found v2.34
    > Checking for GD::Graph (any) ok: found v1.4306
    > Checking for GD::Text::Align (any) ok: found v1.18
    > Checking for PatchReader (v0.9.4) ok: found v0.9.5
    >
    > Checking user setup ...
    >
    > Removing existing compiled templates ...
    > Precompiling templates ...
    > Checking for DBD::Pg (v1.31) ok: found v1.43
    > Checking for PostgreSQL (v7.03.0000) ok: found v07.03.1000
    >
    > Initializing the new Schema storage...
    > Assertion *retlen+1 <= resultant_len+2 failed: file "quote.c", line 319at
    > Bugzi
    > lla/DB.pm line 824.
    > [root@rodrigo bugzilla-2.20]#
    > ---------------
    >
    > Can anybody be of any help? I searched everything but didn't find much on
    > this
    >
    > Thanks in advance,
    > - Rodrigo
    >
    > --
    > There's no place like 127.0.0.1



  2. Re: Installation problem after perl checksetup.pl

    Rodrigo Costa wrote:
    > Hello all,
    >
    > I am trying to install bugzilla locally here in a red hat ws 4
    > machine but I am having the following problem:
    >
    >
    > Removing existing compiled templates ...
    > Precompiling templates ...
    > Checking for DBD::Pg (v1.31) ok: found v1.43
    > Checking for PostgreSQL (v7.03.0000) ok: found v07.03.1000
    >
    > Initializing the new Schema storage...
    > Assertion *retlen+1 <= resultant_len+2 failed: file "quote.c", line
    > 319 at Bugzi
    > lla/DB.pm line 824.
    > [root@rodrigo bugzilla-2.20]#


    Rodrigo,

    This is a problem with DBD::Pg v1.43 remove 1.43 and downgrade to 1.42
    or 1.41. Then try again.

    If it fails with the version of PostgreSQL, edit the localconfig file
    and set the disable_db_check to 1... Note however, that this will bypass
    the creation of the debug database; so, you will have to tell postgreSQL
    to create the database for the bugs user.

    If you need more help, let me know. I'm still waiting for v1.44 which
    is suppose to fix these issues with bugzilla.

    James Kosin

+ Reply to Thread