If you see a warning message that you have an old version of Flash, it
might be the result of incorrect user agent (UA) sniffing. The message
might appear either as a popup or text on a Web page.

Before downloading and installing the latest Flash, check your
configuration at Adobe's official Flash test page
. If you already have the
latest Flash and know how to spoof Firefox, try that to see if the
warning message goes away.

If you have indeed demonstrated that the warning message is a result of
incorrect UA sniffing, please submit a Tech Evangelism bug report.

--
David E. Ross


Go to Mozdev at for quick access to
extensions for Firefox, Thunderbird, SeaMonkey, and other
Mozilla-related applications. You can access Mozdev much
more quickly than you can Mozilla Add-Ons.