Hello,

compiling mod_ssl on a 64-bit system failed for me because the
libraries are located under lib64 paths, rather than just lib paths.
It seems like the following should be the correct fix for these
systems unless I missed some other option to change this (which I
didn't see, but please let me know if I missed it). (Perhaps a --
with-libdir option should be included as a way for people to modify
this as well.) The patch below doesn't include lib64 when SSL_BASE
is provided, so that may need to be applied as well.

Thanks!

-shire


Index: pkg.sslmod/libssl.module
================================================== =================
--- pkg.sslmod/libssl.module (revision 85384)
+++ pkg.sslmod/libssl.module (working copy)
@@ -410,7 +410,7 @@
#
if [ ".$SSL_BASE" = .SYSTEM ]; then
SSL_LIBDIR=""
- for p in . /lib /usr/lib /usr/local/lib; do
+ for p in . /lib64 /usr/lib64 /lib /usr/lib /usr/local/lib; do
if [ -f "$p/libssl.a" -o -f "$p/libssl.so" ]; then
SSL_LIBDIR="$p"
my_real_ssl_libdir="$p"
@@ -419,7 +419,7 @@
done
if [ ".$SSL_LIBDIR" = . ]; then
echo "Error: Cannot find SSL library files in any of
the following dirs:" 1>&2
- echo "Error: . /lib /usr/lib /usr/local/lib" 1>&2
+ echo "Error: . /lib64 /usr/lib64 /lib /usr/lib /usr/
local/lib" 1>&2
exit 1
fi
else

__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org