This is a multi-part message in MIME format.

------_=_NextPart_001_01C7F47F.4E3D277A
Content-Type: text/plain;
charset="US-ASCII"
Content-Transfer-Encoding: quoted-printable

Not sure if these messages are getting through or not. I'm
having trouble with mod_ssl 2.0.55 and apache 2.0.55. The compile and
make goes fine, but when the server is running, and connections are made
via SSL, the child processes segfault. If mod_ssl is compiled into the
apache binary statically, the processes simple hang and build up until
the server can no longer handle the load. When compiled as a shared
module, the segfaults occur. Setting the loglevel to Debug results in
these errors:

=20

[Tue Sep 11 10:10:43 2007] [info] Connection to child 2 established
(server ourserver.name.scrubbed:8040, client )

[Tue Sep 11 10:10:43 2007] [info] Seeding PRNG with 136 bytes of entropy

[Tue Sep 11 10:10:43 2007] [debug] ssl_engine_io.c(1512): OpenSSL: read
11/11 bytes from BIO#401a3500 [mem: 401aabb0] (BIO dump fo

llows)

[Tue Sep 11 10:10:43 2007] [debug] ssl_engine_io.c(1459):
+-----------------------------------------------------------------------

--+

[Tue Sep 11 10:10:43 2007] [debug] ssl_engine_io.c(1484): | 0000: 80 67
01 03 01 00 4e 00-00 00 10 .g....N.... =20

|

[Tue Sep 11 10:10:43 2007] [debug] ssl_engine_io.c(1490):
+-----------------------------------------------------------------------

--+

[Tue Sep 11 10:10:43 2007] [info] SSL library error 1 in handshake
(server ourserver.name.scrubbed:8040, client )

[Tue Sep 11 10:10:43 2007] [info] SSL Library Error: 336027900
error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol

speaking not SSL to HTTPS port!?

[Tue Sep 11 10:10:43 2007] [info] Connection to child 2 closed with
abortive shutdown(server ourserver.name.scrubbed:8040, scrubbed>)

=20

Thoughts anyone?

=20

-Aaron=20

=20


------_=_NextPart_001_01C7F47F.4E3D277A
Content-Type: text/html;
charset="US-ASCII"
Content-Transfer-Encoding: quoted-printable

=3D"urn:schemas-microsoft-comfficeffice" =
xmlns:w=3D"urn:schemas-microsoft-comffice:word" =
xmlns=3D"http://www.w3.org/TR/REC-html40">


charset=3Dus-ascii">









style=3D'font-size:10.0pt;
font-family:Arial'>         =
   Not
sure if these messages are getting through or not.  I’m =
having
trouble with mod_ssl 2.0.55 and apache 2.0.55.  The compile and =
make goes
fine, but when the server is running, and connections are made via SSL, =
the
child processes segfault.  If mod_ssl is compiled into the apache =
binary
statically, the processes simple hang and build up until the server can =
no
longer handle the load.  When compiled as a shared module, the =
segfaults
occur.  Setting the loglevel to Debug results in these =
errors:>>



style=3D'font-size:10.0pt;
font-family:Arial'>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [info] Connection to child =
2
established (server ourserver.name.scrubbed:8040, client <client IP
scrubbed>)>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [info] Seeding PRNG with =
136
bytes of entropy>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [debug] =
ssl_engine_io.c(1512):
OpenSSL: read 11/11 bytes from BIO#401a3500 [mem: 401aabb0] (BIO dump =
fo>>



style=3D'font-size:10.0pt;
font-family:Arial'>llows)>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [debug] =
ssl_engine_io.c(1459):
+-----------------------------------------------------------------------<=
o>>



style=3D'font-size:10.0pt;
font-family:Arial'>--+>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [debug] =
ssl_engine_io.c(1484): |
0000: 80 67 01 03 01 00 4e 00-00 00
10           &nbsp=
;    
..g....N....    >>



style=3D'font-size:10.0pt;
font-family:Arial'>  |>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [debug] =
ssl_engine_io.c(1490):
+-----------------------------------------------------------------------<=
o>>



style=3D'font-size:10.0pt;
font-family:Arial'>--+>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [info] SSL library error 1 =
in
handshake (server ourserver.name.scrubbed:8040, client <client IP
scrubbed>)>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [info] SSL Library Error:
336027900 error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown =
protocol>>



style=3D'font-size:10.0pt;
font-family:Arial'> speaking not SSL to HTTPS =
port!?>>



style=3D'font-size:10.0pt;
font-family:Arial'>[Tue Sep 11 10:10:43 2007] [info] Connection to child =
2
closed with abortive shutdown(server ourserver.name.scrubbed:8040, =
<client IP
scrubbed>)>>



style=3D'font-size:10.0pt;
font-family:Arial'>>



style=3D'font-size:10.0pt;
font-family:Arial'>Thoughts anyone?>>



style=3D'font-size:10.0pt;
font-family:Arial'>>



style=3D'font-size:10.0pt;
font-family:Arial'>-Aaron
 >>



style=3D'font-size:
12.0pt'>>









------_=_NextPart_001_01C7F47F.4E3D277A--
__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org