------=_Part_37556_22315036.1186553742076
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit


Hello at all,

my problem is very difficult, but at least short to describe :-/
The apache crasht after starting if I have included the ssl module.

Okay, let me make the problem a litte bit more difficult as giving you my
system configuration:

- Windows 2k

- Apache 2.2.4

- Win32OpenSSL 0.9.8e (http://www.slproweb.com/products/Win32OpenSSL.html)


I searched for several tutorials to get a running configuration, but there
are all configurations for Apache 1.x. - mostly with the notice that the
configuration for apache 2.x is very different than for 1.x. But I tried it
nevertheless. I have installed openssl, and I created the certificate with
this lines:

req -config openssl.cnf -new -out test-zertifikat.csr

rsa -in privkey.pem -out test-zertifikat.key

x509 -in test-zertifikat.csr -out test-zertifikat.crt -req -signkey
test-zertifikat.key -days 365

x509 -in test-zertifikat.crt -out test-zertifikat.der.crt -outform DER


Then I put the created files into the apache folder (conf/ssl), and changed
the httpd.conf. There I added the following lines at the end of the file:


Listen 8080

Listen 443


LoadModule ssl_module "C:/Apache2.2/modules/mod_ssl.so"



SSLRandomSeed startup builtin

SSLRandomSeed connect builtin



SSLMutex sem

SSLRandomSeed startup builtin

SSLSessionCache none


SSLLog logs/SSL.log

SSLLogLevel info



ServerName webdavtest

DocumentRoot C:/Apache2.2/htdocs/ssl

SSLEngine On

SSLCertificateFile conf/ssl/test-zertifikat.crt

SSLCertificateKeyFile conf/ssl/test-zertifikat.key





Then I start the apache service from the apache monitor, and after 1 second
the start fails with the message: "The requested operation has failed." But
there is no other hint, what could be the problem. All error logs are empty.
So Im very confused about that.

My hope is now, that anybody of you has running the apache 2.2 with ssl
under windows, and can me give some hints. Or does anybody other see, what
could be the problem?

As you see also, I'm not very familiar with the apache configuration. The
mean goal of the project should be, that I can use WebDAV about a secure
https connetion.

Thanks for reading :-)


Regards

Mario Becker-Reinhold

--
View this message in context: http://www.nabble.com/Apache-does-no...html#a12035214
Sent from the mod_ssl - Users mailing list archive at Nabble.com.

------=_Part_37556_22315036.1186553742076
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit


Hello at all,

my problem is very difficult, but at least short to describe :-/
The apache crasht after starting if I have included the ssl module.


Okay, let me make the problem a litte bit more difficult as giving you my system configuration:


- Windows 2k

- Apache 2.2.4

- Win32OpenSSL 0.9.8e (http://www.slproweb.com/products/Win32OpenSSL.html)


I searched for several tutorials to get a running configuration, but there are all configurations for Apache 1.x. - mostly with the notice that the configuration for apache 2.x is very different than for 1.x. But I tried it nevertheless. I have installed openssl, and I created the certificate with this lines:


req -config openssl.cnf -new -out test-zertifikat.csr

rsa -in privkey.pem -out test-zertifikat.key

x509 -in test-zertifikat.csr -out test-zertifikat.crt -req -signkey test-zertifikat.key -days 365

x509 -in test-zertifikat.crt -out test-zertifikat.der.crt -outform DER


Then I put the created files into the apache folder (conf/ssl), and changed the httpd.conf. There I added the following lines at the end of the file:



Listen 8080

Listen 443


LoadModule ssl_module "C:/Apache2.2/modules/mod_ssl.so"




SSLRandomSeed startup builtin

SSLRandomSeed connect builtin




SSLMutex sem

SSLRandomSeed startup builtin

SSLSessionCache none


SSLLog logs/SSL.log

SSLLogLevel info




ServerName webdavtest

DocumentRoot C:/Apache2.2/htdocs/ssl

SSLEngine On

SSLCertificateFile conf/ssl/test-zertifikat.crt

SSLCertificateKeyFile conf/ssl/test-zertifikat.key





Then I start the apache service from the apache monitor, and after 1 second the start fails with the message: "The requested operation has failed." But there is no other hint, what could be the problem. All error logs are empty. So Im very confused about that.


My hope is now, that anybody of you has running the apache 2.2 with ssl under windows, and can me give some hints. Or does anybody other see, what could be the problem?


As you see also, I'm not very familiar with the apache configuration. The mean goal of the project should be, that I can use WebDAV about a secure https connetion.


Thanks for reading :-)



Regards

Mario Becker-Reinhold





View this message in context: Apache does not start after including ssl

Sent from the mod_ssl - Users mailing list archive at Nabble.com.


------=_Part_37556_22315036.1186553742076--

__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org