Sorry for late response on this one. This is what we have in httpd.conf
which is generated at compile time. This problem does not go away even
if I comment out last four lines and restart apache. Could you please
advise what else could be leading apache to think it is https rather
than http?



# Secure (SSL/TLS) connections
#Include conf/extra/httpd-ssl.conf
#
# Note: The following must must be present to support
# starting without SSL on platforms with no /dev/random equivalent
# but a statically compiled-in mod_ssl.
#

SSLRandomSeed startup builtin
SSLRandomSeed connect builtin



With above commented out, when I try to start apache, I get following
passphrase prompt and apache does not start even after saying passphrase
successful, no logs in logs directory although log level is "debug"

]# ./apachectl start
httpd: Could not reliably determine the server's fully qualified domain
name, using 10.3.110.109 for ServerName
Apache/2.2.4 mod_ssl/2.2.4 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide the pass phrases.

Server 10.3.110.109:443 (RSA)
Enter pass phrase:

OK: Pass Phrase Dialog successful.
[root@rh4_109 bin]#

Thanks you very much for your help.


-----Original Message-----
From: owner-modssl-users@modssl.org
[mailtowner-modssl-users@modssl.org] On Behalf Of Omar W. Hannet
Sent: Monday, June 18, 2007 8:34 AM
To: modssl-users@modssl.org
Subject: Re: Apache with mod_ssl

Do you have tags surrounding all
SSL directives in your configuration file? For example:


SSLPassPhraseDialog builtin
# etc.


Saikat Saha wrote:_module>
> Apache was compiled as below
>=20
> ./configure --with-ldap --enable-mods-shared=3D"all ssl ldap cache =

proxy
> authn_alias mem_cache file_cache authnz_ldap charset_lite dav_lock
> disk_cache" --prefix=3D/opt/apache-2.2.4
>=20
> Httpd -l gives below
> [root@rh4_109 bin]# httpd -l
> Compiled in modules:
> core.c
> prefork.c
> http_core.c
> mod_so.c
>=20
> How do I compile so that it does not load mod_ssl automatically and
> loads only if httpd.conf is configured.
>=20
> Surprisingly there are no error logs even at debug level.
>=20
> Thank you so very much for the kind help.
>=20
> -----Original Message-----
> From: owner-modssl-users@modssl.org
> [mailtowner-modssl-users@modssl.org] On Behalf Of Omar W. Hannet
> Sent: Friday, June 15, 2007 4:13 PM
> To: modssl-users@modssl.org
> Subject: Re: Apache with mod_ssl
>=20
> Saikat Saha wrote:
>> We have apache 2.2.4 compiled with all modules but commented out all=20
>> load modules. Do not have anything in httpd.conf file to state that

> this=20
>> is https. But when I start apache, it tries to goto https and prompts


>> for pass phrase. How does apache determine that this is https whereas


>> this is actually a http server.

>=20
> Perhaps mod_ssl is a compiled-in module. Run 'httpd -l' to check

this.
>=20
>> After I enter a passphrase, it shows=20
>> successful but the server never starts up. Can someone please help?

>=20
> The reason probably can be found in Apache's error_log file.
>=20
>> Also can apache support both http and https at different ports at the


>> same time?

>=20
> Yes. The defaults are port 80 for http and port 443 for https.

__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org
__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org