I'm running version 0.9.7a of openssl and I need to update this to
openssl 0.9.8d. openssl is used by my apache installation. To get
apache to use the new openssl library, I need to update modssl. I found
information on updating modssl which told me to do the following once I
had the new version of openssl configured and compiled:

cd //pathtomodssl

../configure \
--with-apxs[=/path/to/apache/bin/apxs] \


make install
make distclean

The end result is suposed to be modssl using the new version of openssl
and apache acknowledging the new libraries. The problem is that when I
run the make command after the ./configure line, I get the following

make[1]: Entering directory
gcc -c -I/workbench/apache/include -DLINUX=22 -DMOD_SSL=208114
-DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite -fpic
-DSHARED_CORE -DSHARED_MODULE -DSSL_ENGINE -I/workbench/openssl/include
-DMOD_SSL_VERSION=\"2.8.14\" mod_ssl.c && mv mod_ssl.o mod_ssl.lo
In file included from mod_ssl.c:65:
mod_ssl.h:349: ndbm.h: No such file or directory
make[1]: *** [mod_ssl.lo] Error 1
make[1]: Leaving directory
make: [all] Error 2 (ignored)

Has anyone come across this before?

Thanks in advance,