Hello,

I am trying to install mod_ssl-2.8.27-1.3.36
and I've faced the following problem when I do 'make' in the
the directory where the apache's source resides:

.....
gcc -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208127 -DUSE_HSREGEX -DEAPI
-DNO_DL_NEEDED `./apaci` -L/home/ahairape/prereqs/openssl-0.9.8b \
-o httpd buildmark.o modules.o modules/standard/libstandard.a
modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a
regex/libregex.a -lm -lcrypt -lssl -lcrypto -lexpat
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x35):
In function `dlfcn_load':
: undefined reference to `dlopen'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x95):
In function `dlfcn_load':
: undefined reference to `dlclose'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0xbc):
In function `dlfcn_load':
: undefined reference to `dlerror'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x147):
In function `dlfcn_bind_var':
: undefined reference to `dlsym'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x172):
In function `dlfcn_bind_var':
: undefined reference to `dlerror'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x237):
In function `dlfcn_bind_func':
: undefined reference to `dlsym'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x262):
In function `dlfcn_bind_func':
: undefined reference to `dlerror'
/home/ahairape/prereqs/openssl-0.9.8b/libcrypto.a(dso_dlfcn.o)(.text+0x52b):
In function `dlfcn_unload':
: undefined reference to `dlclose'

__________________________________________________ _________________________

I've done the following pre-installations:

openssl-0.9.8
apache-1.3.36

And I am following instructions in INSTALL file of mod_ssl to
configure it:

cd mod_ssl-2.8.27-1.3.36
../configure --with-apache=/home/cawebuser/apache_1.3.36 \
--with-ssl=/home/ahairape/prereqs/openssl-0.9.8b \
--prefix=/usr/local/apache-1.3.36

[Here '/home/ahairape/prereqs/openssl-0.9.8b'
is the directory where I've unpacked openssl,
'/home/cawebuser/apache_1.3.36' is the directory
where I've unpacked apache and
/usr/local/apache-1.3.36 is the directory
where the apache is installed]

cd /home/cawebuser/apache_1.3.36
make


Can anybody tell me the solution to this problem?

Thank you in advance,
Arsen.
__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org