Question about apache versions - modssl

This is a discussion on Question about apache versions - modssl ; All, Relative newbie to Apache here. Trying to setup certificate based client authentication for a website. I am a little confused as to why there are versions of Apache available - Apache 1.3, 2.0 and 2.2? Does Apache 2.2 superceed ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Question about apache versions

  1. Question about apache versions

    All,

    Relative newbie to Apache here. Trying to setup certificate based
    client authentication for a website.
    I am a little confused as to why there are versions of Apache available
    - Apache 1.3, 2.0 and 2.2?

    Does Apache 2.2 superceed the other two versions? Which version should
    I go with?

    Thanks,
    Ash


  2. Re: Question about apache versions

    "Ash" schreef in bericht
    news:1137705976.078324.290220@g47g2000cwa.googlegr oups.com...
    > Relative newbie to Apache here. Trying to setup certificate based
    > client authentication for a website.
    > I am a little confused as to why there are versions of Apache available
    > - Apache 1.3, 2.0 and 2.2?

    - Some third-party modules are (still) unavailb\able for the 2.x versions.
    - Some third-party modules -pe mod_ssl- or part of their functionallity -pe
    mod-gzip versus mod_deflate- are now part of the standard distribution of
    version 2.x

    - http://httpd.apache.org/docs/2.0/new_features_2_0.html
    total internal overhaul: so not all have jumped into an update
    threading: although an option scared the h*l out of many
    non-unix support: only some running Novell, BeOS,OS/2 or MSW may have
    jumped into this
    IPv6: not yet used by most of us

    - http://httpd.apache.org/docs/2.2/new_features_2_2.html
    improvements in caching and proxying,

    > Which version should I go with?

    Depends highly on the cross-platform|version availability of third-party
    modules you may want to use.


    HansH



+ Reply to Thread