Sorry for the repost but there is a bug report also open at
http://issues.apache.org/bugzilla/show_bug.cgi?id=11232
The bug id is 11232.

Hi,

I have the following setup of Apache on Win 32.

Apache running only on port 443 with SSL enabled and proxying enabled.

I am using the precompiled binaries available at
http://www.apache.org/dyn/closer.cgi/perl/win32-bin/

The normal usage is like this:

web client <-https connection to proxy-> Apache Proxy on port 443 <-normal
processing of proxy request-> Remote web server.

The connection between the web client and the proxy is https or ssl
encrypted. The connection between the proxy and the remote web server may or
may not be.

This setup works fine as long as the client issues only GET and POST
requests. But when the client issues a CONNECT request (to reach a secure
remote web server via the secure proxy) the proxy server abruptly drops the
connection after a few seconds.

Without an SSL connection between the client and the proxy CONNECT works
fine.

The problem exists both on the latest version of apache 1.3 and 2.0. I have
tested them on a winxp box.

Possibly mod_ssl on win32 is not able to handle streams of unknown length
properly?

Is it possible to have a stable port of OpenSSL/mod_ssl on win32 ?

Regards,
Emmanuel

--
Geschenkt: 3 Monate GMX ProMail gratis + 3 Ausgaben stern gratis
++ Jetzt anmelden & testen ++ http://www.gmx.net/de/go/promail ++

--
Weitersagen: GMX DSL-Flatrates mit Tempo-Garantie!
Ab 4,99 Euro/Monat: http://www.gmx.net/de/go/dsl
__________________________________________________ ____________________
Apache Interface to OpenSSL (mod_ssl) www.modssl.org
User Support Mailing List modssl-users@modssl.org
Automated List Manager majordomo@modssl.org