Hi, I wish to setup a GUI debugging environment for my CGI, which is running
using apache mod_perl

I update the following file (/usr/local/apache_modperl/conf/httpd.conf) to
the below content :-

### Start to hack by Cheok

use Apache:B();
Apache:B->init;


PerlFixupHandler Apache:B

### End to hack by Cheok

and the following file (/usr/local/lib/perl/5.8.8/Apache/DB.pm)

if (!$loaded_db) {
# Fallback
# require 'Apache/perl5db.pl';
# Hacked by Cheok
require Devel:tkdb;
}

When I launch a web site, I get the following error log :-

[yanchengdev] [modperl] Prototype mismatch: sub CORE::GLOBAL::exit: none vs
(;$) at /usr/local/lib/perl/5.8.8/Tk.pm line 414. [failed] [Connection
refused]
[yanchengdev] [modperl] [Wed Nov 5 10:48:53 2008] [notice] child pid 15698
exit signal Segmentation fault (11) [success]
[yanchengdev] [modperl] Prototype mismatch: sub CORE::GLOBAL::exit: none vs
(;$) at /usr/local/lib/perl/5.8.8/Tk.pm line 414. [failed] [Connection
refused]
[yanchengdev] [modperl] [Wed Nov 5 10:48:54 2008] [notice] child pid 15699
exit signal Segmentation fault (11) [success]

OK. I temporary solve the problem by comment out the line

## *CORE::GLOBAL::exit = \&exit;

I try to test whether TK/Perl debugging tool still work by

(1) ssh -X root@remotemachine
(2) cat cheok.cgi

#!/usr/bin/perl5 -Twdtkdb

print "Hello World From Cheok.\n";
print "Good Bye World.\n";

(3) /usr/bin/perl5 -T cheok.cgi

OK. The GUI windows shown up, and I can perform step debugging.

Now, I try to test on the web site. I want to start my apache in single
process mode. Hence, I edit the following files

/usr/local/apache_modperl/bin/apachectl
/etc/init.d/apache

to content (I just add -X flag)

case "$1" in
start)
log_begin_msg "Starting $NAME 1.3 web server..."
if $ENV $SSD --start --pidfile $PIDFILE --make-pidfile $PIDFILE --exec
$DAEMON --oknodo --verbose -- -X -f $CONF; then

Then I run

yanchengdev:/$ /usr/local/apache_modperl/bin/apachectl stop
Stopping apache 1.3 web server....
yanchengdev:/$ /usr/local/apache_modperl/bin/apachectl start
Starting apache 1.3 web server...GnuPlot already exists in [/tmp/]. Skipping
copy.
PRELOADING SCRIPTS...
Regenerating autold...done.
[notice] Apache:B initialized in child 17975
GnuPlot already exists in [/tmp/]. Skipping copy.
PRELOADING SCRIPTS...
Regenerating autold...done.

I use my browser to request cheok.cgi

The web page is displayed at browser. But there are no GUI debugger windows
at all.

I check the error log file in apache, there isn't any error

Any hint? I am lost...

Cheok
--
View this message in context: http://www.nabble.com/Problem-Settin...p20358148.html
Sent from the mod_perl - General mailing list archive at Nabble.com.