This is a multipart message in MIME format.

--Boundary_(ID_FkXtoXjOjd1kukBSH7gISQ)
Content-type: text/plain; charset=windows-1250
Content-transfer-encoding: quoted-printable

Hey there

=20

I=92m looking for more information on this subject.

I=92m using mod_perl2 and apache2

=20

Currently what I=92m trying to do is to make both the page and the DBI =
module
tainted-enabled

=20

I have =96t enabled in httpd.conf

And {Taint =3D> 1} upon the DBI connection call.

=20

I=92ve made modifications to a test case page,which was a perfect =
replicate,of
a real =93commercial=94 page.

so now supposedly all $apr->param() parameters are no longer tainted =
after
numereious regexp equations and a temporary hash table that holds all =
data.

=20

Problem is,

When DBI =93Taint=94 is on, the page is completely stuck and I cannot =
find any
errors or warning in the error_log.

=20

Any recommendations / different techniques ?

=20

Thanks.


No virus found in this outgoing message.
Checked by AVG.=20
Version: 7.5.524 / Virus Database: 269.23.2/1387 - Release Date: =
19/04/2008
11:31
=20

--Boundary_(ID_FkXtoXjOjd1kukBSH7gISQ)
Content-type: text/html; charset=windows-1250
Content-transfer-encoding: 7BIT

="urn:schemas-microsoft-comfficeffice" xmlns:w="urn:schemas-microsoft-comffice:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">














Hey there>>



>



I’m looking for more information on this subject.>>



I’m using mod_perl2 and apache2>>



>



Currently what I’m trying to do is to make both the page
and the DBI module tainted-enabled>>



>



I have –t enabled in httpd.conf>>



And {Taint => 1} upon the DBI connection call.>>



>



I’ve made modifications to a test case page,which was
a perfect replicate,of a real “commercial” page.>>



so now supposedly all $apr->param() parameters are no
longer tainted after numereious regexp equations and a temporary hash table
that holds all data.>>



>



Problem is,>>



When DBI “Taint” is on, the page is completely
stuck and I cannot find any errors or warning in the error_log.>>



>



Any recommendations / different techniques ?>>



>



Thanks.>>











No virus found in this outgoing message.

Checked by AVG.

Version: 7.5.524 / Virus Database: 269.23.2/1387 - Release Date: 19/04/2008 11:31



--Boundary_(ID_FkXtoXjOjd1kukBSH7gISQ)--