Hi
I have a complete installation of Cygwin on Windows XP Professional and have made the following attempts to install mod-perl 2.0 on the same
1. installed apache 2.2.8
2. Installed ActiveState 10x
3. downloaded mpinstall
4. perl mpinstall from dos prompt
C:\ActiveStatePerl\bin\ppm install mod_perl-2.0.ppd
ppm install failed: The PPD does not provide code to install for this platform
system C:\ActiveStatePerl\bin\ppm install mod_perl-2.0.ppd failed: 256 at mpinst
all line 242.

I have also tried to download and install httpd-2.2.8.tar.gz under cygwin as below
I untarred this tarball and ran configure followed by make and then make install.

A few questions given my relative inexperience working with web-apps/servers/etc, much less with perl-based solutions. I am trying to get the environment in place to get my feet wet with MayPole
1) How do I resolve the error pasted above (ppm install failed, etc)?
2) How do I continue with installing mod-perl under cygwin? A related question: If the make install and configure has been error-free, how do I start / stop the Apache server from under Cygwin? Does it or does it not conflict with the installation done using a Windows Installer at C:/Program Files/Apache Software Foundation, etc?

Thanks
Dunston




__________________________________________________ __________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i...Dypao8Wcj9tAcJ





__________________________________________________ __________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i...Dypao8Wcj9tAcJ