Configuration error :: Used "Location" where I should have used "Directory."

"Actual" perl.conf file had something like:

SetHandler perl-script
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
Options +ExecCGI


-Brett

----- Original Message ----
From: brett lee
To: mod_perl list
Sent: Wednesday, January 23, 2008 10:38:17 AM
Subject: /perl-status shows no compiled registry scripts


Am running on a newer OS and not seeing any compiled registry scripts
when looking at "/perl-status." Am refreshing to look at several PIDs,
so I suspect a config error on my part. Have found nothing relevant in
the logs.

The "/server-info" shows mod_perl.c as well as the perl.conf entries,
and "/perl-status -> loaded modules" shows ModPerl::Registry.

What am I forgetting? Thanks!

CentOS 5.1
mod_perl-2.0.2-6.3.el5
perl-5.8.8-10

From: /etc/httpd/conf.d/perl.conf
------------------------------------------------
PerlConfigRequire /etc/httpd/conf.d/startup.pl
PerlModule ModPerl::Registry

Alias /perl /var/www/perl

SetHandler perl-script
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
Options +ExecCGI



SetHandler perl-script
PerlResponseHandler Apache2::Status



From "startup.pl'
-------------------------------
#!/usr/bin/perl -w
use lib qw(/var/www/perl);
use ModPerl::Registry ();
1;







__________________________________________________ __________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now.
http://mobile.yahoo.com/;_ylt=Ahu06i...Dypao8Wcj9tAcJ






__________________________________________________ __________________________________
Never miss a thing. Make Yahoo your home page.
http://www.yahoo.com/r/hs