Hi Everyone,

I'm using a small script to use the Crypt::RSA module under windows using
Active Perl v5.8.8 but it is showing Perl Command Line Interpreter has
encountered a problem and needs to close...

My script....
#############################
#!/usr/bin/perl
use strict;
use warnings;
use Crypt::RSA;
# Use my to declare variables
my ($crypted, $data, $plain, $private, $public, $rsa);
# Set the data that will be encrypted
$data = "hello";

# Create a new RSA object
$rsa = new Crypt::RSA or die "Unable to create RSA object!\r\n";

# Generate a public private key pair
($public, $private) = $rsa->keygen(Size => 1024) or
die "Unable to create key pair!\r\n";

undef($rsa);
########################

Could any body please suggest what may be the parameter for the function
call $rsa->keygen(....

Thanks in advance.

Arnab


--
View this message in context: http://www.nabble.com/Can%27t-use-Cr...p14524284.html
Sent from the mod_perl - General mailing list archive at Nabble.com.