What's your modperl config like?

Ian G. Tyndall wrote:
> Ok, I decided to upgrade my Apache to see if that would fix things.
>
> I installed 2.2.4, and I was getting the same error as originally
> reported... but more often.
> Then, I upgraded to 2.2.6 from the Apachelounge... and now I'm getting
> an error.
>
> The error is as follows:
>
> [Tue Oct 09 08:50:20 2007] [error] [client 192.168.3.28] failed to
> resolve handler `ModPerl::Registry': Can't load
> 'X:/perl/5.8.8/site/lib/auto/Apache2/RequestRec/RequestRec.dll' for
> module Apache2::RequestRec: load_file:The specified procedure could not
> be found at X:/perl/5.8.8/lib/XSLoader.pm line 64.\n at
> X:/perl/5.8.8/site/lib/Apache2/XSLoader.pm line 31\nCompilation failed
> in require at X:/perl/5.8.8/site/lib/ModPerl/RegistryCooker.pm line
> 32.\nBEGIN failed--compilation aborted at
> X:/perl/5.8.8/site/lib/ModPerl/RegistryCooker.pm line 32.\nCompilation
> failed in require at (eval 5) line 3.\n\t...propagated at
> X:/perl/5.8.8/lib/base.pm line 91.\nBEGIN failed--compilation aborted at
> X:/perl/5.8.8/site/lib/ModPerl/Registry.pm line 26.\nCompilation failed
> in require at (eval 4) line 3.\n
>
> I did do a fresh install of ModPerl 2.0.3, and I've seen similar "failed
> to resolve handler" messages on the web... but nothing like this.
>
> Any suggestions/thoughts!
>
> Thanks again,
> Ian
>
>
> -----Original Message-----
> From: Randy Kobes [mailto:randy@theoryx5.uwinnipeg.ca]
> Sent: Thursday, October 04, 2007 3:40 PM
> To: Ian G. Tyndall
> Cc: modperl@perl.apache.org
> Subject: Re: Apache crashing
>
> On Thu, 4 Oct 2007, Ian G. Tyndall wrote:
>
>
>> Oh the problems come and go so quickly!
>>
>> I've got one cgi script that always crashes apache. The error log
>> gives the following message:
>>
>> [Thu Oct 04 11:38:29 2007] [crit] (22)Invalid argument: Parent: Failed
>>

>
>
>> to create the child process.
>> [Thu Oct 04 11:38:29 2007] [crit] (OS 6)The handle is invalid. :
>> master_main: create child process failed. Exiting.
>> [Thu Oct 04 11:38:29 2007] [notice] Parent: Forcing termination of
>> child process 2474288
>>
>> Other scripts run fine... so what would be the best way of debugging
>> this.
>>
>> I'm in the process of commenting out modules/code, but no luck so
>>

> far...
>
>> any recommendations?
>>
>> I'm using mod_perl 2.0.3, perl 5.8.8, apache 2.0.59 on a Windows 2003
>> server.
>>
>> Thanks,
>> Ian
>>

>
> Is this a cgi script, or a mod_perl registry script?
> Although the log messages are generic, similar messages appear when one
> tries to restart apache with mod_perl enabled - if it's a cgi script,
> does commenting out the loading of mod_perl.so help?
>
> As for tracking down the problem, reducing it to a minimal version will
> help. If you can do this, and don't see the problem, try posting it to
> the list here. Also, trying some of the debugging tips suggested in the
> thread
> http://marc.info/?t=119137677000001&r=1&w=2
> may help, along with installing
> http://www.apache.org/dist/httpd/binaries/win32/#source
> to help in the crash analysis.
>
> --
> best regards,
> Randy
>