Peter von Weisz wrote:
> Hi all,
>
> Sorry for posting such a long compiler output.
>
> This is on Scientific Linux (SL) 4.3 (a RedHat EL-based dist) with Apache
> 2.0.52 installed as an RPM. SL supplies a RPM called mod_perl-1.99_16-4
> (which is installed), but that is not enough for the Apache::AuthCookie
> module that I need to run. There is no update in SL for the mod_perl RPM and
> this leads me to trying to build mod_perl2 from source.
>
> I have the apache source downloaded, ./configure'd & make'd in the
> /usr/src/httpd-2.0.52 dir.
> Something is terribly wrong, could someone give me a hint (or a RTFM
> pointer)?


Did you 'make install' in /usr/src/httpd-2.0.52?
Once you do that, it will probably install apache in '/usr/local/apache'
unless you specified a --prefix option. Then configure mod_perl with
'perl Makefile.PL MP_APXS=/usr/local/apache/bin/apxs', or use the path
to wherever apxs was installed.

Also, remove the mod_perl-1.99_16-4 rpm to avoid any potential
conflicts. For more installation details see
http://perl.apache.org/docs/2.0/user...l#Installation