On Wed, 2006-09-27 at 14:05 -0400, Jesse Erlbaum wrote:
> I'm in the process of migrating a mod_perl site from Apache 1.3 to
> Apache 2. I'm using RedHat ES4, which ships with Perl 5.8.5, Apache
> 2.0.52, and mod_perl 1.99_16.


That mod_perl has known problems. It's a few years old too. I'm sure
they want to use official packages, but it's just not a good idea to use
that.

> PerlSetEnv PERL5LIB '/path/to/my/modules'


Have you tried doing a use lib in httpd.conf instead? I think it would
be something like this:


use lib qw(/path/to/my/modules);


> (FYI, I've tried both "PerlSwitches -I" and "PerlSwitches -Mlib=", to no avail.)


That might work if you upgraded to a newer mod_perl.

- Perrin