On Wed, 26 Jul 2006 07:22:15 -0700 (PDT)
philge philip wrote:

> Next I added the lines:
> =20
> LoadModule perl_module modules/mod_perl.so=20
> PerlModule Apache2
> =20
> to httpd.conf
> =20
> when I tried restarting the server I got an error like ' cant
> locate perl module \nApache2.pm module in @INC\' \nThough I corrected
> this error once and when I tried to load Apache2::Request\n module in
> the script I got an error like \'cant locate perl module
> Apache2::Request.pm in @INC\'. \n \nI tried installing the
> libapreq2-2.07 module to include Apache2::Request module but I am
> unable to load it.\n \n \nPlease guide me how to load the Apache2.pm
> module and load Apache2::request module when such an error \ncome.I
> have a doubt whether I have to upgrade our Perl version and whether
> Fedora3 will support higher versions of perl?Kindly guide me=85 \n
> \nYours Sincerely
>=20
> ",1] ); //--> cant locate perl module Apache2.pm module in @INC'
> Though I corrected this error once and when I tried to load
> Apache2::Request module in the script I got an error like 'cant
> locate perl module Apache2::Request.pm in @INC'. I tried installing
> the libapreq2-2.07 module to include Apache2::Request module but I am
> unable to load it. Please guide me how to load the Apache2.pm module
> and load Apache2::request module when such an error come.I have a
> doubt whether I have to upgrade our Perl version and whether Fedora3
> will support higher versions of perl?Kindly guide me=85 Philge Philip


You don't need to use Apache2 any longer, that was changed several
versions ago before mod_perl 2.0 was released. =20

Also, make sure you're installing libapreq via the Makefile.PL so
that it installs the Perl bindings for you. =20

---------------------------------
Frank Wiles
http://www.wiles.org
---------------------------------