-------------8<---------- Start Bug Report ------------8<----------
1. Problem Description:

I have tried MP2 2.0.2 and the most recent dev version.
Both of them gave me the same compile error message.
===
waiting 120 seconds for server to start: .[Wed Jul 19 15:08:44 2006] [warn] Useless use of AllowOverride in line 959.
..[Wed Jul 19 15:08:45 2006] [info] 6 Apache2:: modules loaded
[Wed Jul 19 15:08:45 2006] [info] 0 APR:: modules loaded
[Wed Jul 19 15:08:45 2006] [info] base server + 30 vhosts ready to run tests
....[Wed Jul 19 15:08:48 2006] [error] Insecure directory in $ENV{PATH} while running with -T switch at /s5/twh/papache/modperl-2.0/Apache-Test/lib/Apache/TestConfig.pm line 1106.\nCompilation failed in require at /s5/twh/papache/modperl-2.0/t/conf/modperl_startup.pl line 18.\n\t...propagated at /s5/twh/papache/modperl-2.0/t/conf/modperl_startup.pl line 19.\nBEGIN failed--compilation aborted at /s5/twh/papache/modperl-2.0/t/conf/modperl_startup.pl line 36.\nCompilation failed in require at (eval 2) line 1.\n
[Wed Jul 19 15:08:48 2006] [error] Can't load Perl file: /s5/twh/papache/modperl-2.0/t/conf/modperl_startup.pl for server localhost:8529, exiting...


2. Used Components and their Configuration:

*** mod_perl version 2.000003

*** using /s5/twh/papache/modperl-2.0/lib/Apache2/BuildConfig.pm

*** Makefile.PL options:
MP_APR_LIB => aprext
MP_APXS => /s5/twh/apache2ssl/bin/apxs
MP_COMPAT_1X => 1
MP_DEBUG => 1
MP_GENERATE_XS => 1
MP_LIBNAME => mod_perl
MP_TRACE => 1
MP_USE_DSO => 1


*** /s5/twh/apache2ssl/bin/httpd -V
Server version: Apache/2.2.2
Server built: Jul 14 2006 14:02:51
Server's Module Magic Number: 20051115:2
Server loaded: APR 1.2.7, APR-Util 1.2.7
Compiled using: APR 1.2.7, APR-Util 1.2.7
Architecture: 32-bit
Server MPM: Prefork
threaded: no
forked: yes (variable process count)
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_FCNTL_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D DYNAMIC_MODULE_LIMIT=128
-D HTTPD_ROOT="/s5/twh/apache2ssl"
-D SUEXEC_BIN="/s5/twh/apache2ssl/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"

*** /usr/bin/ldd /s5/twh/apache2ssl/bin/httpd
libssl.so.0.9.8 => /opt/exp/lib/openssl/lib/libssl.so.0.9.8
libcrypto.so.0.9.8 => /opt/exp/lib/openssl/lib/libcrypto.so.0.9.8
libm.so.1 => /usr/lib//libm.so.1
libaprutil-1.so.0 => /s5/twh/apache2ssl/lib/libaprutil-1.so.0
libexpat.so.0 => /s5/twh/apache2ssl/lib/libexpat.so.0
libapr-1.so.0 => /s5/twh/apache2ssl/lib/libapr-1.so.0
librt.so.1 => /usr/lib//librt.so.1
libsocket.so.1 => /usr/lib//libsocket.so.1
libnsl.so.1 => /usr/lib//libnsl.so.1
libpthread.so.1 => /usr/lib//libpthread.so.1
libc.so.1 => /usr/lib//libc.so.1
libgcc_s.so.1 => /opt/exp/gnu/lib/libgcc_s.so.1
libdl.so.1 => /usr/lib//libdl.so.1
libaio.so.1 => /usr/lib//libaio.so.1
libmp.so.2 => /usr/lib//libmp.so.2
libthread.so.1 => /usr/lib//libthread.so.1
/usr/platform/SUNW,Ultra-Enterprise/lib/libc_psr.so.1


*** (apr|apu)-config linking info

-L/s5/twh/apache2ssl/lib -laprutil-1 -lexpat -L/s5/twh/apache2ssl/lib
-L/s5/twh/apache2ssl/lib -lapr-1 -lrt -lsocket -lnsl -lpthread



*** /opt1/perl580/bin/perl -V
Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
Platform:
osname=solaris, osvers=2.8, archname=sun4-solaris
uname='sunos ln 5.8 generic_117350-01 sun4u sparc sunw,ultra-enterprise solaris '
config_args='-Dcc=gcc -B/usr/ccs/bin/ -Dprefix=/opt1/perl580'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='gcc -B/usr/ccs/bin/', ccflags ='-fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/opt/exp/gnu/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
optimize='-O',
cppflags='-fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/opt/exp/gnu/include'
ccversion='', gccversion='3.4.4', gccosandvers='solaris2.8'
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
alignbytes=8, prototype=define
Linker and Libraries:
ld='gcc -B/usr/ccs/bin/', ldflags =' '
libpth=/opt/exp/gnu/lib /usr/lib /usr/ccs/lib
libs=-lsocket -lnsl -ldb -ldl -lm -lc
perllibs=-lsocket -lnsl -ldl -lm -lc
libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' -Wl,-E'
cccdlflags='-fPIC', lddlflags=' -Wl,-E -G'


Characteristics of this binary (from libperl):
Compile-time options: PERL_MALLOC_WRAP USE_LARGE_FILES USE_PERLIO
Built under solaris
Compiled at Mar 15 2006 16:52:00
%ENV:
PERL_LWP_USE_HTTP_10="1"
@INC:
/opt1/perl580/lib/5.8.8/sun4-solaris
/opt1/perl580/lib/5.8.8
/opt1/perl580/lib/site_perl/5.8.8/sun4-solaris
/opt1/perl580/lib/site_perl/5.8.8
/opt1/perl580/lib/site_perl/5.8.7/sun4-solaris
/opt1/perl580/lib/site_perl/5.8.7
/opt1/perl580/lib/site_perl/5.8.5/sun4-solaris
/opt1/perl580/lib/site_perl/5.8.5
/opt1/perl580/lib/site_perl/5.8.2/sun4-solaris
/opt1/perl580/lib/site_perl/5.8.2
/opt1/perl580/lib/site_perl