Are the t/apr-ext/*.t tests supposed to fail? No matter how hard to
try I always get this on OpenBSD 3.9 with perl 5.8.8, Apache-2.2.2
and mod_perl-2:

Failed Test Stat Wstat Total Fail Failed List
of Failed
------------------------------------------------------------------------
-------
t/apache/content_length_header.t 27 1 3.70% 17
t/api/status.t 6 2 33.33% 4-5
t/apr-ext/base64.t 0 11 3 6 200.00% 1-3
t/apr-ext/brigade.t 2 512 ?? ?? % ??
t/apr-ext/bucket.t 2 512 ?? ?? % ??
t/apr-ext/date.t 0 11 14 28 200.00% 1-14
t/apr-ext/finfo.t 2 512 ?? ?? % ??
t/apr-ext/pool.t 2 512 ?? ?? % ??
t/apr-ext/string.t 0 11 5 10 200.00% 1-5
t/apr-ext/table.t 2 512 ?? ?? % ??
t/apr-ext/threadmutex.t 2 512 ?? ?? % ??
t/apr-ext/uri.t 2 512 ?? ?? % ??
t/apr-ext/util.t 0 11 4 8 200.00% 1-4
t/apr-ext/uuid.t 0 11 3 4 133.33% 2-3
8 tests skipped.
Failed 14/231 test scripts, 93.94% okay. 31/2049 subtests failed,
98.49% okay.
[warning] server localhost.my.domain:8529 shutdown
[ error] error running tests (please examine t/logs/error_log)
+--------------------------------------------------------+
| Please file a bug report: http://perl.apache.org/bugs/ |
+--------------------------------------------------------+

They all fail with errors such as:

t/apr-ext/brigade......................./home/rutski89/opt/perl/bin/
perl:/home/rutski89/opt/kit/mod_perl-2.0.2/blib/arch/auto/APR/Pool/
Pool.so: undefined symbol 'apr_pool_cleanup_null'
Can't load '/home/rutski89/opt/kit/mod_perl-2.0.2/blib/arch/auto/APR/
Pool/Pool.so' for module APR::Pool: Cannot load specified object at /
home/rutski89/opt/perl/lib/5.8.8/OpenBSD.i386-openbsd/DynaLoader.pm
line 230.
at /home/rutski89/opt/kit/mod_perl-2.0.2/blib/lib/APR/XSLoader.pm
line 30
Compilation failed in require at /home/rutski89/opt/kit/
mod_perl-2.0.2/t/lib/TestAPRlib/brigade.pm line 14.
BEGIN failed--compilation aborted at /home/rutski89/opt/kit/
mod_perl-2.0.2/t/lib/TestAPRlib/brigade.pm line 14.
Compilation failed in require at t/apr-ext/brigade.t line 7.
BEGIN failed--compilation aborted at t/apr-ext/brigade.t line 7.

Note that the t/apr/*.t tests all pass, it's the t/apr-ext/*.t test
that are all failing. I tried this on Debian and it worked without
errors, these errors seem to occur only when I do this on OpenBSD,
but I can't even begin to imagine why.