On Mon, 15 May 2006, Tracy E Schreiber wrote:

> Hi,
>
> I hope this isn't too much of a newbie question...
>
> I am trying to upgrade from Apache 2.0.55 using mod_perl
> V1.0 to Apache 2.2.2 using mod_perl V2.0. This
> installation is on a Windows XP Pro SP2 machine. I get
> this error:
>
> httpd.exe: Syntax error on line 31 of
> D:/Apache2.2/conf/httpd.conf: Cannot load
> D:/Apache2.2/modules/mod_perl.so into server: The
> specified module could not be found.
>
> The module is in the directory. Am I doing something wrong or is the module
> not compatible with Apache 2.2.2?


Assuming you got the mod_perl package through our ppm
repository at http://theoryx5.uwinnipeg.ca/ppms/, you're
right that it's a compatibility issue; the mod_perl ppm
package was compiled with Apache/2.0, and such modules
aren't compatible with Apache/2.2. I've put up a
mod_perl-2.2 ppm package in this repository that was
compiled against Apache/2.2 - try installing that to
see if that helps.

--
best regards,
Randy Kobes