This is a multi-part message in MIME format.

------=_NextPart_000_0047_01C67843.B3CDF8C0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


"Tracy E Schreiber" wrote in message news:...

Hi Lionel,

Thank you for your response....

I have these lines in httpd.conf:

LoadFile "D:/Program Files/Perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so

I have ActivePerl 5.8.8. The mod_perl.so I have is the the most recent =
binary=20
available from the mod_perl site.

Tracy

"Lionel MARTIN" wrote in message =
news:BAY103-DAV12BECC890BF44C2FF597C1A8A30@phx.gbl...
> Hi,
>=20
> I don't think that's a question of path, as you are telling us that =

you=20
> checked that, and that the file was there.
> Actually, I think this is a compilation problem, between mod_perl =

and perl=20
> itself (Apache has nothing to do with that right now).
>=20
> I'm running under Windows as well, and I made extensive tests, to =

find out=20
> which version of mod_perl.so is working with which version of =

perl58.dll.
> (hoping that you didn't forget to load this latter one in your =

httpd.conf,=20
> before mod_perl.so !)
>=20
> I suppose that, as a Win32 user, you're using the ActivePerl =

distribution?
> If this is the case, then, I suggest that you use and install the =

latest=20
> version of Perl (v5.8.8) with the latest version of mod_perl =

(including=20
> among others mod_perl.so). You can use the ppm utility to check for =

your=20
> versions and/or update accordingly.
>=20
> Lionel.
>=20
> ----- Original Message -----=20
> From: "Philip M. Gollucci"
> To: "Tracy E Schreiber"
> Cc:
> Sent: Tuesday, May 16, 2006 12:01 AM
> Subject: Re: Cannot load mod_perl.so
>=20
>=20
>> Tracy E Schreiber wrote:
>>> Hi,
>>>
>>> I hope this isn't too much of a newbie question...
>>>
>>> I am trying to upgrade from Apache 2.0.55 using mod_perl V1.0 to =

Apache=20
>>> 2.2.2 using mod_perl V2.0. This installation is on a Windows XP =

Pro SP2=20
>>> machine. I get this error:

>> You mean V2.0 -- no 1.x version works with 2.x and vice verusa.
>>
>>
>>> httpd.exe: Syntax error on line 31 of =

D:/Apache2.2/conf/httpd.conf:=20
>>> Cannot load
>>> D:/Apache2.2/modules/mod_perl.so into server: The specified module =

could=20
>>> not be
>>> found.

>> Permisions ?
>>
>>
>>> The module is in the directory. Am I doing something wrong or is =

the=20
>>> module not compatible with Apache 2.2.2?

>> LoadModule perl_module libexec/apache22/mod_perl.so
>>
>> changing the paths appropriately of course.
>>
>> =

------------------------------------------------------------------------
>> Philip M. Gollucci (pgollucci@p6m7g8.com) 323.219.4708
>> Consultant / http://p6m7g8.net/Resume/resume.shtml
>> Senior Software Engineer - TicketMaster - http://ticketmaster.com
>> 1024D/A79997FA F357 0FDD 2301 6296 690F 6A47 D55A 7172 A799 97F
>>
>> "It takes a minute to have a crush on someone, an hour to like =

someone,
>> and a day to love someone, but it takes a lifetime to forget =

someone..."
>>=20

>

------=_NextPart_000_0047_01C67843.B3CDF8C0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable



charset=3Diso-8859-1">




 

style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
"Tracy E Schreiber" < href=3D"mailto:tes@cncdsl.com">tes@cncdsl.com> wrote in message =

news:...

 

Hi Lionel,

 

Thank you for your response....

 


I have these lines in httpd.conf:

 

LoadFile "D:/Program Files/Perl/bin/perl58.dll"
LoadModule =
perl_module=20
modules/mod_perl.so

 

I have ActivePerl 5.8.8. The mod_perl.so I have is the the most =
recent=20
binary

available from the mod_perl site.

 

Tracy

 

"Lionel MARTIN" < href=3D"mailto:martinlio@hotmail.com">martinlio@hotmail.com> =
wrote in=20
message =
href=3D"news:BAY103-DAV12BECC890BF44C2FF597C1A8A30@phx.gbl">news:BAY103-D=
AV12BECC890BF44C2FF597C1A8A30@phx.gbl...

> Hi,
>
> I don't think that's a question of =
path, as you=20
are telling us that you
> checked that, and that the file was=20
there.
> Actually, I think this is a compilation problem, =
between=20
mod_perl and perl
> itself (Apache has nothing to do with that =
right=20
now).
>
> I'm running under Windows as well, and I made =
extensive=20
tests, to find out
> which version of mod_perl.so is working =
with which=20
version of perl58.dll.
> (hoping that you didn't forget to load =
this=20
latter one in your httpd.conf,
> before mod_perl.so !)

>
> I suppose that, as a Win32 user, you're using the=20
ActivePerl distribution?
> If this is the case, then, I suggest =
that you=20
use and install the latest
> version of Perl (v5.8.8) with the =
latest=20
version of mod_perl (including
> among others mod_perl.so). You =
can use=20
the ppm utility to check for your
> versions and/or update=20
accordingly.
>
> Lionel.
>
> ----- Original =
Message=20
-----
> From: "Philip M. Gollucci" < =
href=3D"mailtogollucci@p6m7g8.com">pgollucci@p6m7g8.com>
>=
To:=20
"Tracy E Schreiber" < href=3D"mailto:tes@cncdsl.com">tes@cncdsl.com>
> Cc: =
< =
href=3D"mailto:modperl@perl.apache.org">modperl@perl.apache.org> R>>=20
Sent: Tuesday, May 16, 2006 12:01 AM
> Subject: Re: Cannot load=20
mod_perl.so
>
>
>> Tracy E Schreiber=20
wrote:
>>> Hi,
>>>
>>> I hope this =
isn't=20
too much of a newbie question...
>>>
>>> I am =
trying=20
to upgrade from Apache 2.0.55 using mod_perl V1.0 to Apache =

>>>=20
2.2.2 using mod_perl V2.0. This installation is on a Windows XP Pro =
SP2=20

>>> machine. I get this error:
>> You mean V2.0 =
-- no=20
1.x version works with 2.x and vice=20
verusa.
>>
>>
>>> httpd.exe: Syntax =
error on=20
line 31 of D:/Apache2.2/conf/httpd.conf:
>>> Cannot=20
load
>>> D:/Apache2.2/modules/mod_perl.so into server: The =

specified module could
>>> not be
>>>=20
found.
>> Permisions =
?
>>
>>
>>> The=20
module is in the directory. Am I doing something wrong or is the=20

>>> module not compatible with Apache 2.2.2?
>>=20
LoadModule perl_module =
libexec/apache22/mod_perl.so
>>
>>=20
changing the paths appropriately of course.
>>
>>=20
=
------------------------------------------------------------------------<=
BR>>>=20
Philip M. Gollucci ( href=3D"mailtogollucci@p6m7g8.com">pgollucci@p6m7g8.com)=20
323.219.4708
>> Consultant / =
href=3D"http://p6m7g8.net/Resume/resume.shtml">http://p6m7g8.net/Resume/r=
esume.shtml
>>=20
Senior Software Engineer - TicketMaster - =
href=3D"http://ticketmaster.com">http://ticketmaster.com
>> =

1024D/A79997FA F357 0FDD 2301 6296 690F  6A47 D55A 7172 A799=20
97F
>>
>> "It takes a minute to have a crush on =
someone, an=20
hour to like someone,
>> and a day to love someone, but it =
takes a=20
lifetime to forget someone..."
>>=20

>


------=_NextPart_000_0047_01C67843.B3CDF8C0--