(I hope my english is not too bad as I am German)

Hi, I'm running here XP prof. SP2 with additional Updates.

There are two external USB harddrives in use: 160GB & 320 GB.
The bigger one (320GB) is approx half full. When I plug it in
appearing the window:

"Autoplay
[cancel]"
I press cancel and XP *cancels* for about *20* *seconds* (after it has
scanned all the data on the harddisk as it seems. This might take even
longer when there is more stuff on the harddisk). This window closes
appearing a new window

"Autoplay
[cancel]"
When I press cancel this time wind really reacts and I get a window

"This disk contains more than on type of content
What do you want wind to do"?
-> Take No action [OK]

Unfortunately Wind is too stupid :-( to remember this. Or it might be
a feature not to remember this :-)

There is a regpatch that switches off all autoplay:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies
\Explorer]
"NoDriveTypeAutoRun"=dword:000000fd

fd means "all drives".

Unfortunately this only works for admin users. Applying this registry
patch no drive uses autoplay / autorun - but for admin logins only :-(

When I try to apply it for the non admin users it says
"Cannot import ..\NoAutoplay.reg: Not all data was successfully
written to the registry. Some keys are open by the system or other
processes."

Might there be another address in the registry where I must apply the
"NoDriveTypeAutoRun" for Non-Admin-Logins?

Any help is greatly appreciated

Greetings
D