Help - Can't upgrade from 2007 to 2009 - Mandriva

This is a discussion on Help - Can't upgrade from 2007 to 2009 - Mandriva ; I'm trying to upgrade using the instructions outlined in the Makdriva wiki's 2009 notes: http://wiki.mandriva.com/en/2009.0_N...om_2008_Spring However after downloading the files, they all fail to install, giving me the following error message: "rpmlib(PayloadIsLzma) installed. Can anyone give me an idea why ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Help - Can't upgrade from 2007 to 2009

  1. Help - Can't upgrade from 2007 to 2009

    I'm trying to upgrade using the instructions outlined in the Makdriva
    wiki's 2009 notes:

    http://wiki.mandriva.com/en/2009.0_N...om_2008_Spring

    However after downloading the files, they all fail to install, giving me
    the following error message:

    "rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by" the package being
    installed.

    Can anyone give me an idea why this is happening and what I have to do to
    eliminate the problem?

    rpm -qa | grep rpm
    rpm-4.4.6-12mdv2007.0
    rpmdrake-3.19-1.1mdv2007.0
    librpmconstant0-0.1.2-1mdv2007.0
    rpm-mandriva-setup-1.29-3mdv2007.0
    rpmtools-5.1.0-1mdv2007.0
    rpm-helper-0.21.3-1mdv2007.0
    rpm-mandriva-setup-build-1.29-3mdv2007.0 gurpmi-4.8.28-1mdv2007.0
    rpmbuildupdate-0.7.1-1mdv2007.0
    python-rpm-4.4.6-12mdv2007.0
    librpm4.4-4.4.6-12mdv2007.0
    rpmlint-0.77-3mdv2007.0
    rpm-rebuilder-0.27-1mdk
    deltarpm-3.3-2mdk
    urpmi-4.8.28-1mdv2007.0
    rpm-build-4.4.6-12mdv2007.0

    Thanks!
    George


  2. Re: Help - Can't upgrade from 2007 to 2009

    George Czerw wrote:
    > I'm trying to upgrade using the instructions outlined in the Makdriva
    > wiki's 2009 notes:
    >
    > However after downloading the files, they all fail to install, giving me
    > the following error message:
    >
    > "rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by" the package being
    > installed.




    Did you look in Mandriva Linux 2009.0 Eratta, under Installation issues

    http://wiki.mandriva.com/en/2009.0_E...Spring_to_2009

    Might that apply to your case as well, even though you are starting
    with 2007?

    Or, you might simply try repeatedly running
    urpmi --auto --auto-select --replacefiles

    Also, if rpmlib is needed, perhaps urpmi rpmlib to get the required
    version? (Assuming it is the new version needed -- otherwise you need
    to install the new package, perhaps with --force or --allow-nodeps.
    This would seem a likely path into dependency hell, though, so I
    would try repeated use of the urpmi --auto --auto-select --replace
    files first.

    Cheers!

    jim b.

    --
    UNIX is not user unfriendly; it merely
    expects users to be computer-friendly.

  3. Re: Help - Can't upgrade from 2007 to 2009

    On Tue, 11 Nov 2008 13:36:49 -0500, Jim Beard wrote:

    > George Czerw wrote:
    >> I'm trying to upgrade using the instructions outlined in the Makdriva
    >> wiki's 2009 notes:
    >>
    >> However after downloading the files, they all fail to install, giving
    >> me the following error message:
    >>
    >> "rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by" the package being
    >> installed.

    >
    >
    >
    > Did you look in Mandriva Linux 2009.0 Eratta, under Installation issues
    >
    > http://wiki.mandriva.com/en/2009.0_E...r_doing_an_in-

    line_upgrade_from_2008_Spring_to_2009
    >
    > Might that apply to your case as well, even though you are starting with
    > 2007?
    >
    > Or, you might simply try repeatedly running urpmi --auto --auto-select
    > --replacefiles
    >
    > Also, if rpmlib is needed, perhaps urpmi rpmlib to get the required
    > version? (Assuming it is the new version needed -- otherwise you need to
    > install the new package, perhaps with --force or --allow-nodeps. This
    > would seem a likely path into dependency hell, though, so I would try
    > repeated use of the urpmi --auto --auto-select --replace files first.
    >
    > Cheers!
    >
    > jim b.


    Jim,

    Thanks for the reply. Repeatedly running urpmi --auto --auto-select
    --replacefiles against the 2009 repositories does nothing. Even with --
    force and/or --allow-nodeps nothing will install, and the same error
    messages appear for each package. I even tried urpmi rpm using the 2009
    repositories, hoping that installing the new RPM packages would install,
    but they too failed, giving me the same error message!

    If I go back to the 2007 repositories and urpmi rpm, all I get is "The
    package(s) are already installed". Trying urpmi rpmlib yields "no package
    named rpmlib".

    Right now, all that I have is one, big "Catch 22"!

    George


  4. Re: Help - Can't upgrade from 2007 to 2009

    On Tue, 11 Nov 2008 19:06:40 +0000 (UTC), George Czerw wrote:

    > Thanks for the reply. Repeatedly running urpmi --auto --auto-select
    > --replacefiles against the 2009 repositories does nothing.


    Just for fun, go though and Remove/Delete all mirrors which do not
    contain a check mark.

    I noticed I would not get updates when my mirror list had unused mirrors.

    I would then run the command
    urpmi --wget --auto-update --auto

  5. Re: Help - Can't upgrade from 2007 to 2009

    On Tue, 11 Nov 2008 19:35:18 +0000, Bit Twister wrote:

    > On Tue, 11 Nov 2008 19:06:40 +0000 (UTC), George Czerw wrote:
    >
    >> Thanks for the reply. Repeatedly running urpmi --auto --auto-select
    >> --replacefiles against the 2009 repositories does nothing.

    >
    > Just for fun, go though and Remove/Delete all mirrors which do not
    > contain a check mark.
    >
    > I noticed I would not get updates when my mirror list had unused
    > mirrors.
    >
    > I would then run the command
    > urpmi --wget --auto-update --auto


    I'm getting the RPMs from the 2009 repositories, the problem is that they
    won't install and give me the rpmlib error message. Removed the 2009
    repositories and reloaded the 2007 repositories, none are unchecked.
    Running urpmi --wget --auto-update --auto against the 2007 repositories
    now, 1/2 hour into it but not to the point that anything is being
    downloaded yet.


  6. Re: Help - Can't upgrade from 2007 to 2009

    On Tue, 11 Nov 2008 20:13:39 +0000 (UTC), George Czerw wrote:

    > I'm getting the RPMs from the 2009 repositories, the problem is that they
    > won't install and give me the rpmlib error message. Removed the 2009
    > repositories and reloaded the 2007 repositories, none are unchecked.


    I would never recommend updating between major releases, let alone go
    more than one.

    I have see people post problems with their upgrades. Once they decided
    to do a clean install, their problems went away.


+ Reply to Thread