2008.0 Services and Daemons: Many On boot processes do not start - Mandriva

This is a discussion on 2008.0 Services and Daemons: Many On boot processes do not start - Mandriva ; Previously, I'd noticed that haldaemon did not autostart (though it was marked "On boot"). Last boot, there are quite a number of processes that didn't autostart-- even though I know they used to start automatically. Where do I begin to ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: 2008.0 Services and Daemons: Many On boot processes do not start

  1. 2008.0 Services and Daemons: Many On boot processes do not start

    Previously, I'd noticed that haldaemon did not autostart (though it was
    marked "On boot"). Last boot, there are quite a number of processes
    that didn't autostart-- even though I know they used to start automatically.

    Where do I begin to look for the problem? :-\

    Paul

  2. Re: 2008.0 Services and Daemons: Many On boot processes do not start

    On Thursday 16 October 2008 07:45, someone identifying as *Paul Hanchett*
    wrote in /alt.os.linux.mandriva:/

    > Previously, I'd noticed that haldaemon did not autostart (though it was
    > marked "On boot"). Last boot, there are quite a number of processes
    > that didn't autostart-- even though I know they used to start
    > automatically.
    >
    > Where do I begin to look for the problem? :-\


    Check */var/log/messages* - it's usually a good place to start. Some
    daemons may or may not also keep error logs in */var/log.*

    Mileage and distro versions will vary. :-)

    --
    *Aragorn*
    (registered GNU/Linux user #223157)

  3. Re: 2008.0 Services and Daemons: Many On boot processes do not start

    On Thu, 16 Oct 2008 01:45:21 -0400, Paul Hanchett wrote:

    > Previously, I'd noticed that haldaemon did not autostart (though it was
    > marked "On boot"). Last boot, there are quite a number of processes
    > that didn't autostart-- even though I know they used to start automatically.


    I expect checking /var/log/prcsys.log will show that haldaemon is trying to
    start before messagebus, which will not work. Something has messed up
    the parrellel init startup order.

    Try running (as root) ...
    chkconfig messagebus reset
    chkconfig haldaemon reset

    Then reboot. I don't know which update(s) cause the startup order to get messed up,
    but the above has worked for a number of people who have encountered the problem.

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  4. Re: 2008.0 Services and Daemons: Many On boot processes do not start

    Paul Hanchett wrote:

    > Previously, I'd noticed that haldaemon did not autostart (though it was
    > marked "On boot"). Last boot, there are quite a number of processes
    > that didn't autostart-- even though I know they used to start
    > automatically.
    >
    > Where do I begin to look for the problem? :-\


    It's a known BUG:
    https://qa.mandriva.com/show_bug.cgi?id=42618

    To fix the initscripts, as root run this command:

    for l in /etc/rc.d/rc5.d/S99*; do s=${l#*/S99}; chkconfig --del $s;
    chkconfig --add $s; done

    And ignore the "error reading information about service S99local: No such
    file or directory" messages.

    Then reboot.

    --
    Web Dreamer


+ Reply to Thread