bitter "tea" with OpenOffice, Mandriva 2008.1 - Mandriva

This is a discussion on bitter "tea" with OpenOffice, Mandriva 2008.1 - Mandriva ; On a Mandriva 2008.1 system that is being upgraded urpmi openoffice.org also loaded java-1.7.0-icedtea-plugin-1.7.0.0-24.614.2mdv2008.1 java-1.7.0-icedtea-1.7.0.0-24.614.2mdv2008.1 This in spite of the fact that Mandriva itself had already installed jre-1.6.0_07-fcs So now there are two versions of java. That wouldn't be so ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: bitter "tea" with OpenOffice, Mandriva 2008.1

  1. bitter "tea" with OpenOffice, Mandriva 2008.1

    On a Mandriva 2008.1 system that is being upgraded

    urpmi openoffice.org

    also loaded

    java-1.7.0-icedtea-plugin-1.7.0.0-24.614.2mdv2008.1
    java-1.7.0-icedtea-1.7.0.0-24.614.2mdv2008.1

    This in spite of the fact that Mandriva itself had already installed

    jre-1.6.0_07-fcs

    So now there are two versions of java. That wouldn't be so bad, except
    that it made the "icedtea" one the default, and the "icedtea" one does
    not work with TrippLite's PowerAlert console software. Doing:

    service pa console

    puts up a window, but the mouse doesn't work within that window, so
    nothing can be selected, including the "x" close window box. For now I
    have hacked /etc/rc.d/init.d/pa to hardwire it to use the jre Java.
    All of which makes me wonder if the openoffice Java parts are going to
    have similar issues.

    Under 2007.1 the OpenOffice rpm did not bring its own java (or was at
    least satisfied with the one already on the system and didn't load it
    too). However, under 2008.1 it is (<- indicates dependency):

    java-1.7.0-icedtea-1.7.0.0-24.614.2mdv2008.1 <-
    openoffice.org-java-common-2.4.1.5-2.3mdv2008.1.i586 <-
    openoffice.org-base-2.4.1.5-2.3mdv2008.1.i586 <-
    the rest of OpenOffice

    I understand what "icedtea" is about, but why must the OpenOffice RPMs
    use it instead of the (apparently better functioning) JRE?

    Thanks,

    David Mathog

  2. Re: bitter "tea" with OpenOffice, Mandriva 2008.1

    David Mathog wrote:

    [...]
    > I understand what "icedtea" is about, but why must the
    > OpenOffice RPMs use it instead of the (apparently better
    > functioning) JRE?


    As previously posted, suggest that you also pursue these
    questions on the official forums from Mandriva:

    http://forum.mandriva.com

    Regards
    Syd H
    Suffolk UK


  3. Re: bitter "tea" with OpenOffice, Mandriva 2008.1

    On Tue, 26 Aug 2008 13:05:32 -0700, David Mathog wrote:
    > On a Mandriva 2008.1 system that is being upgraded
    >
    > urpmi openoffice.org
    >
    > also loaded
    >
    > java-1.7.0-icedtea-plugin-1.7.0.0-24.614.2mdv2008.1
    > java-1.7.0-icedtea-1.7.0.0-24.614.2mdv2008.1
    >
    > This in spite of the fact that Mandriva itself had already installed
    >
    > jre-1.6.0_07-fcs
    >
    > So now there are two versions of java. That wouldn't be so bad, except
    > that it made the "icedtea" one the default, and the "icedtea" one does
    > not work with TrippLite's PowerAlert console software. Doing:


    Yes and I have no faith that icetea's jre is getting security updates I
    see for Sun's jre.

    Wording found at http://java.com/en/download/installed.jsp does not
    help for icetea users either.

+ Reply to Thread