Establishing a CDMA modem connection using wvdial no internetconnectivity - Mandriva

This is a discussion on Establishing a CDMA modem connection using wvdial no internetconnectivity - Mandriva ; Hi all, I am trying to use TATA Indicom CDMA USB modem on Mandriva Linux 2008 using wvdial. I have edited wvdial.conf file as per company's suggestion and it looks as follows: [Dialer Defaults] Init1 = ATZ Init2 = ATQ0 ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Establishing a CDMA modem connection using wvdial no internetconnectivity

  1. Establishing a CDMA modem connection using wvdial no internetconnectivity

    Hi all,

    I am trying to use TATA Indicom CDMA USB modem on Mandriva Linux 2008
    using wvdial.
    I have edited wvdial.conf file as per company's suggestion and it
    looks as follows:

    [Dialer Defaults]
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    stupid mode = 1
    Modem Type = USB Modem
    ISDN = 0
    +FCLASS = 0
    Phone = #777
    Modem = /dev/ttyACM0
    Username = internet
    Password = internet
    Baud = 460800


    I know it works because I have used it on Open SUSE on same computer
    and have got no problems.

    On Mandriva, when I run wvdial and then disconnect using Ctrl+C, I get
    following output:

    [root@localhost kedar]# wvdial
    --> WvDial: Internet dialer version 1.56 (abuild@mandelbrot)
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT#777
    --> Waiting for carrier.
    ATDT#777
    CONNECT
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Tue Aug 26 08:00:01 2008
    --> Pid of pppd: 6954
    --> Using interface ppp0
    --> pppd: h[16][06][08]�[1e][06][08]
    --> pppd: h[16][06][08]�[1e][06][08]
    --> pppd: h[16][06][08]�[1e][06][08]
    --> pppd: h[16][06][08]�[1e][06][08]
    --> local IP address 121.245.41.169
    --> pppd: h[16][06][08]�[1e][06][08]
    --> remote IP address 172.23.129.14
    --> pppd: h[16][06][08]�[1e][06][08]
    --> primary DNS address 203.197.12.30
    --> pppd: h[16][06][08]�[1e][06][08]
    --> secondary DNS address 202.54.1.18
    --> pppd: h[16][06][08]�[1e][06][08]
    Caught signal 2: Attempting to exit gracefully...
    --> Terminating on signal 15
    --> pppd: h[16][06][08]�[1e][06][08]
    --> Connect time 0.6 minutes.
    --> pppd: h[16][06][08]�[1e][06][08]
    --> pppd: h[16][06][08]�[1e][06][08]
    --> Disconnecting at Tue Aug 26 08:00:40 2008

    If I ping primary or secondary DNS, I get following output:

    From 121.245.41.169 icmp_seq=1 Destination Host Unreachable

    --- 203.197.12.30 ping statistics ---
    0 packets transmitted, 0 received, +48575 errors

    On one blog I found that wvdial requires a file /etc/resolve.conf with
    IP addresses of primary and secondary DNS. I manually created the file
    but problem persisted. I have also tried adding the two IP addresses
    in hosts file using Mandriva Linux Control Centre, but no solution.


    What is happening ? Because of this I am not able to connect to the
    internet.

    Regards,
    Kedar

  2. Re: Establishing a CDMA modem connection using wvdial no internetconnectivity

    On Mon, 25 Aug 2008 23:33:06 -0400, damkedar@gmail.com wrote:

    > Hi all,
    >
    > I am trying to use TATA Indicom CDMA USB modem on Mandriva Linux 2008
    > using wvdial.
    > Modem = /dev/ttyACM0


    Try changing the above to
    Modem=/dev/ttyUSB0

    The number may be different.
    Disconnect, and then reconnect the modem. Run "dmesg|tail -n 25". There
    should be lines showing which ttyUSB# has been assigned, to the modem.

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  3. Re: Establishing a CDMA modem connection using wvdial no internetconnectivity

    On Aug 26, 8:07*pm, "David W. Hodgins"
    wrote:
    > On Mon, 25 Aug 2008 23:33:06 -0400, damke...@gmail.com wrote:
    > > Hi all,

    >
    > > I am trying to use TATA Indicom CDMA USB modem on Mandriva Linux 2008
    > > using wvdial.
    > > Modem = /dev/ttyACM0

    >
    > Try changing the above to
    > Modem=/dev/ttyUSB0
    >

    My modem is recognised in Mandriva Control Centre. I am able to dial
    connection. The system tray notification says connected. But no web
    page is displayed. So I don't think there is point in changing to /dev/
    ttyUSB0.
    I had tried doing that but modem is not recognised as USB0.

+ Reply to Thread