Wireshark 2008.0 - Mandriva

This is a discussion on Wireshark 2008.0 - Mandriva ; Post from Klaatu (ISP dropped usenet so using Google for now) Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates, application hangs. When run from konsole I get # wireshark capset(): Operation not permitted capset(): Operation not permitted capset(): ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: Wireshark 2008.0

  1. Wireshark 2008.0

    Post from Klaatu (ISP dropped usenet so using Google for now)

    Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    application hangs. When run from konsole I get

    # wireshark
    capset(): Operation not permitted
    capset(): Operation not permitted
    capset(): Operation not permitted
    capset(): Operation not permitted
    10:01:47 Warn Unknown message from dumpcap, try to show it as
    a string: capset(): Operation not permitted
    capset(): Operation not permitted

    Tcpdump works okay. See references to a kernel module and bind when
    googling but doing "modprobe capset" just returns a module not found
    error. Any ideas?

    TIA

  2. Re: Wireshark 2008.0

    On Mon, 7 Jan 2008 09:31:37 -0800 (PST), houndnews@gmail.com wrote:
    > Post from Klaatu (ISP dropped usenet so using Google for now)
    >
    > Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    > application hangs.


    Shucky dern, you are right. Open a bug report if one does not already
    exists at http://qa.mandriva.com/


  3. Re: Wireshark 2008.0

    On Jan 7, 10:38*am, Bit Twister wrote:
    > On Mon, 7 Jan 2008 09:31:37 -0800 (PST), houndn...@gmail.com wrote:
    > > Post from Klaatu (ISP dropped usenet so using Google for now)

    >
    > > Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    > > application hangs.

    >
    > Shucky dern, you are right. Open a bug report if one does not already
    > exists athttp://qa.mandriva.com/


    From Klaatu: Looks like the bug was just recently filed

    http://qa.mandriva.com/show_bug.cgi?id=36470

    Compiling from source reported to fix problem.

  4. Re: Wireshark 2008.0

    On Mon, 07 Jan 2008 12:31:37 -0500, wrote:

    > Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    > application hangs. When run from konsole I get
    > # wireshark
    > capset(): Operation not permitted


    I'm now getting the same error. Wasn't getting it last time I ran
    wireshark, which was probably about two weeks ago, so some recent
    update, has to be at fault.

    # rpm -q -changelog wireshark
    * Wed Dec 26 2007 Gustavo De Nardin 0.99.7-0.1mdv2008.0
    - 0.99.7: security fixes for CVE-2007-6111, CVE-2007-6112, CVE-2007-6113,
    CVE-2007-6114, CVE-2007-6115, CVE-2007-6116, CVE-2007-6117, CVE-2007-6118,
    CVE-2007-6119, CVE-2007-6120, CVE-2007-6121, CVE-2007-6438, CVE-2007-6439,
    CVE-2007-6441, CVE-2007-6450, CVE-2007-6451
    - P1: fix plugin directory specification (from Cooker)

    On my system, the update was installed Jan. 3rd, 2008.

    From http://www.mail-archive.com/debian-b.../msg12130.html
    I found the running "modprobe capability", and adding capability to
    /etc/modprobe.preload fixes the problem.

    Bug reported as
    http://qa.mandriva.com/show_bug.cgi?id=36550

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  5. Re: Wireshark 2008.0

    On Mon, 07 Jan 2008 12:59:45 -0500, wrote:

    > From Klaatu: Looks like the bug was just recently filed
    > http://qa.mandriva.com/show_bug.cgi?id=36470


    Looks like I didn't read throught the already submitted bugs,
    prior to submintting 36550.

    Note that loading the module capability, via modprobe, or adding it
    to /etc/modprobe.preload and rebooting, will fix the problem.

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  6. Re: Wireshark 2008.0

    houndnews@gmail.com wrote:
    > Post from Klaatu (ISP dropped usenet so using Google for now)
    >
    > Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    > application hangs.


    New on the mirrors:
    wireshark-0.99.7-0.2mdv2008.0

    Cheers!

    jim b.

    --
    UNIX is not user-unfriendly; it merely
    expects users to be computer-friendly.

  7. Re: Wireshark 2008.0

    On Tue, 08 Jan 2008 04:52:52 GMT, Jim Beard wrote:

    > New on the mirrors:
    > wireshark-0.99.7-0.2mdv2008.0


    Not at ussg.iu.edu yet.


  8. Re: Wireshark 2008.0

    Bit Twister wrote:

    > On Mon, 7 Jan 2008 09:31:37 -0800 (PST), houndnews@gmail.com wrote:
    >> Post from Klaatu (ISP dropped usenet so using Google for now)
    >>
    >> Trying to run wireshark gui 0.99.7-0.1 in 2008.0 all updates,
    >> application hangs.

    >
    > Shucky dern, you are right. Open a bug report if one does not already
    > exists at http://qa.mandriva.com/


    That's a disgrace to the good name of shark!

    --
    Blinky
    Killing all posts from Google Groups
    The Usenet Improvement Project - http://improve-usenet.org


+ Reply to Thread