no sound Mandriva 2008 - Mandriva

This is a discussion on no sound Mandriva 2008 - Mandriva ; After configured the wireless with the help of this newsgroup now I've got no sound in my laptop toshiba. Alsaconf found the following card: hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio Controller but no sound. The command lspci | ...

+ Reply to Thread
Results 1 to 20 of 20

Thread: no sound Mandriva 2008

  1. no sound Mandriva 2008

    After configured the wireless with the help of this newsgroup now I've
    got no sound in my laptop toshiba. Alsaconf found the following card:
    hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    Controller but no sound.
    The command lspci | grep Multimedia is:

    > 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

    and in cat /etc/modprobe.d/sound
    > alias snd-card-0 snd-hda-intel
    > alias sound-slot-0 snd-hda-intel

    Can anyone, please, help me? Thanks in advance. Oder.

  2. Re: no sound Mandriva 2008

    Oder wrote:

    > After configured the wireless with the help of this newsgroup now I've
    > got no sound in my laptop toshiba. Alsaconf found the following card:
    > hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    > Controller but no sound.
    > The command lspci | grep Multimedia is:
    >
    >> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card
    >> Reader (SD/MMC/MS/MS PRO/xD)

    > and in cat /etc/modprobe.d/sound
    >> alias snd-card-0 snd-hda-intel
    >> alias sound-slot-0 snd-hda-intel

    > Can anyone, please, help me? Thanks in advance. Oder.



    I believe that the 2.6.22.12 kernel includes a bug-fix related to that chip.
    Upgrading to that kernel may resolve your problem. If the new kernel is not
    on your mirror now, it should be soon.

    Jim

  3. Re: no sound Mandriva 2008

    On Thu, 29 Nov 2007 09:54:18 -0200, Oder wrote:

    > After configured the wireless with the help of this newsgroup now I've
    > got no sound in my laptop toshiba. Alsaconf found the following card:
    > hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    > Controller but no sound.
    > The command lspci | grep Multimedia is:
    >
    >> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia
    >> Card Reader (SD/MMC/MS/MS PRO/xD)

    > and in cat /etc/modprobe.d/sound
    >> alias snd-card-0 snd-hda-intel
    >> alias sound-slot-0 snd-hda-intel

    > Can anyone, please, help me? Thanks in advance. Oder.


    1. Run (as root): alsamixer
    2. Unmute master volume and others as needed (by pressing the M key) 3.
    Run (as root): alsactl store

    Done.


    --
    "Ubuntu" -- an African word, meaning "Slackware is too hard for me".


  4. Re: no sound Mandriva 2008

    Dan C wrote:
    > On Thu, 29 Nov 2007 09:54:18 -0200, Oder wrote:
    >
    >> After configured the wireless with the help of this newsgroup now I've
    >> got no sound in my laptop toshiba. Alsaconf found the following card:
    >> hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    >> Controller but no sound.
    >> The command lspci | grep Multimedia is:
    >>
    >>> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia
    >>> Card Reader (SD/MMC/MS/MS PRO/xD)

    >> and in cat /etc/modprobe.d/sound
    >>> alias snd-card-0 snd-hda-intel
    >>> alias sound-slot-0 snd-hda-intel

    >> Can anyone, please, help me? Thanks in advance. Oder.

    >
    > 1. Run (as root): alsamixer
    > 2. Unmute master volume and others as needed (by pressing the M key) 3.
    > Run (as root): alsactl store
    >
    > Done.
    >
    >

    Thanks. I did this and get:
    > Card: HDA Intel ?
    > ? Chip: Conexant CX20549 (Venice) ?
    > ? View: [Playback] Capture All ?
    > ? Item: Master [dB gain=-6.00, -6.00] ?
    > ? ?
    > ? ?
    > ? ?
    > ? ???? ???? ???? ???? ?
    > ? ? ? ???? ? ? ? ? ?
    > ? ???? ???? ? ? ? ? ?
    > ? ???? ???? ? ? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ? ? ?
    > ? ???? ???? ???? ???? ???? ?
    > ? ?MM? ?MM? ?MM? ?MM? ?
    > ? ???? ???? ???? ???? ?
    > ? 91<>91 100<>100 78<>78 0<>0 ?
    > ? < Master > PCM IEC958 Ext Mic Int Mic ?
    > ? ?
    > ?


    But KMix is closed and no sound.
    That is correct? I'm newbie with linux and probably
    has a mistake.
    Cheers, Oder.

  5. Re: no sound Mandriva 2008

    On Thu, 29 Nov 2007 14:54:56 -0200, Oder wrote:

    > Dan C wrote:
    >> On Thu, 29 Nov 2007 09:54:18 -0200, Oder wrote:
    >>
    >>> After configured the wireless with the help of this newsgroup now I've
    >>> got no sound in my laptop toshiba. Alsaconf found the following card:
    >>> hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    >>> Controller but no sound.
    >>> The command lspci | grep Multimedia is:
    >>>
    >>>> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia
    >>>> Card Reader (SD/MMC/MS/MS PRO/xD)
    >>> and in cat /etc/modprobe.d/sound
    >>>> alias snd-card-0 snd-hda-intel
    >>>> alias sound-slot-0 snd-hda-intel
    >>> Can anyone, please, help me? Thanks in advance. Oder.

    >>
    >> 1. Run (as root): alsamixer
    >> 2. Unmute master volume and others as needed (by pressing the M key) 3.
    >> Run (as root): alsactl store
    >>
    >> Done.
    >>
    >>

    > Thanks. I did this and get:
    >> Card: HDA Intel ?
    >> ? Chip: Conexant CX20549 (Venice) ?
    >> ? View: [Playback] Capture All ?
    >> ? Item: Master [dB gain=-6.00, -6.00] ?
    >> ? ?
    >> ? ?
    >> ? ?
    >> ? ???? ???? ???? ???? ?
    >> ? ? ? ???? ? ? ? ? ?
    >> ? ???? ???? ? ? ? ? ?
    >> ? ???? ???? ? ? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ? ? ?
    >> ? ???? ???? ???? ???? ???? ?
    >> ? ?MM? ?MM? ?MM? ?MM? ?
    >> ? ???? ???? ???? ???? ?
    >> ? 91<>91 100<>100 78<>78 0<>0 ?
    >> ? < Master > PCM IEC958 Ext Mic Int Mic ?
    >> ? ?
    >> ?

    >
    > But KMix is closed and no sound.
    > That is correct? I'm newbie with linux and probably
    > has a mistake.
    > Cheers, Oder.


    I don't know what KMix is, but look for something like "external
    amplifier" in the alsamixer screen, and turn it off (mute/M) if it's on.
    Then do "alsactl store" again and see what you get.


    --
    "Ubuntu" -- an African word, meaning "Slackware is too hard for me".


  6. Re: no sound Mandriva 2008

    James Kerr wrote:
    > Oder wrote:
    >
    >> After configured the wireless with the help of this newsgroup now I've
    >> got no sound in my laptop toshiba. Alsaconf found the following card:
    >> hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    >> Controller but no sound.
    >> The command lspci | grep Multimedia is:
    >>
    >>> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card
    >>> Reader (SD/MMC/MS/MS PRO/xD)

    >> and in cat /etc/modprobe.d/sound
    >>> alias snd-card-0 snd-hda-intel
    >>> alias sound-slot-0 snd-hda-intel

    >> Can anyone, please, help me? Thanks in advance. Oder.

    >
    >
    > I believe that the 2.6.22.12 kernel includes a bug-fix related to that chip.
    > Upgrading to that kernel may resolve your problem. If the new kernel is not
    > on your mirror now, it should be soon.
    >
    > Jim

    Unfortunately I have this kernel - > [root@localhost oder]# uname -a
    > Linux localhost 2.6.22.12-laptop-1mdv #1 SMP Tue Nov 20 09:05:54 EST 2007 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GNU/Linux

    and I don't know how to solve the problem.
    But, thanks, Oder.

  7. Re: no sound Mandriva 2008

    Em Quinta, 29 de Novembro de 2007 11:54, Oder escreveu:

    > After configured the wireless with the help of this newsgroup now I've
    > got no sound in my laptop toshiba. Alsaconf found the following card:
    > hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    > Controller but no sound.
    > The command lspci | grep Multimedia is:
    >
    >> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card
    >> Reader (SD/MMC/MS/MS PRO/xD)

    > and in cat /etc/modprobe.d/sound
    >> alias snd-card-0 snd-hda-intel
    >> alias sound-slot-0 snd-hda-intel

    > Can anyone, please, help me? Thanks in advance. Oder.


    post the outputs of this two commands as root

    lsmod|grep snd

    cat /proc/asound/cards



  8. Re: no sound Mandriva 2008

    ArameFarpado wrote:
    > Em Quinta, 29 de Novembro de 2007 11:54, Oder escreveu:
    >
    >> After configured the wireless with the help of this newsgroup now I've
    >> got no sound in my laptop toshiba. Alsaconf found the following card:
    >> hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    >> Controller but no sound.
    >> The command lspci | grep Multimedia is:
    >>
    >>> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card
    >>> Reader (SD/MMC/MS/MS PRO/xD)

    >> and in cat /etc/modprobe.d/sound
    >>> alias snd-card-0 snd-hda-intel
    >>> alias sound-slot-0 snd-hda-intel

    >> Can anyone, please, help me? Thanks in advance. Oder.

    >
    > post the outputs of this two commands as root
    >
    > lsmod|grep snd
    >
    > cat /proc/asound/cards
    >
    >

    The output 1
    > [root@localhost oder]# lsmod | grep snd
    > snd_seq_dummy 3492 0
    > snd_seq_oss 29888 0
    > snd_seq_midi_event 6912 1 snd_seq_oss
    > snd_seq 46800 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    > snd_seq_device 7276 3 snd_seq_dummy,snd_seq_oss,snd_seq
    > snd_pcm_oss 37216 0
    > snd_mixer_oss 14784 1 snd_pcm_oss
    > snd_hda_intel 284700 4
    > snd_pcm 69636 3 snd_pcm_oss,snd_hda_intel
    > snd_timer 19652 3 snd_seq,snd_pcm
    > snd_page_alloc 8456 2 snd_hda_intel,snd_pcm
    > snd_hwdep 7492 1 snd_hda_intel
    > snd 45092 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
    > soundcore 6624 1 snd


    The output 2
    > [root@localhost oder]# cat /proc/asound/cards
    > 0 [Intel ]: HDA-Intel - HDA Intel
    > HDA Intel at 0xd0340000 irq 21


    Thanks, Oder.

  9. Re: no sound Mandriva 2008

    Em Sexta, 30 de Novembro de 2007 09:12, Oder escreveu:

    > The output 1
    >> [root@localhost oder]# lsmod | grep snd
    >> snd_seq_dummy 3492 0
    >> snd_seq_oss 29888 0
    >> snd_seq_midi_event 6912 1 snd_seq_oss
    >> snd_seq 46800 5
    >> snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    >> snd_seq_device 7276 3 snd_seq_dummy,snd_seq_oss,snd_seq
    >> snd_pcm_oss 37216 0
    >> snd_mixer_oss 14784 1 snd_pcm_oss
    >> snd_hda_intel 284700 4
    >> snd_pcm 69636 3 snd_pcm_oss,snd_hda_intel
    >> snd_timer 19652 3 snd_seq,snd_pcm
    >> snd_page_alloc 8456 2 snd_hda_intel,snd_pcm
    >> snd_hwdep 7492 1 snd_hda_intel
    >> snd 45092 15
    >>

    snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
    >> soundcore 6624 1 snd

    >
    > The output 2
    >> [root@localhost oder]# cat /proc/asound/cards
    >> 0 [Intel ]: HDA-Intel - HDA Intel
    >> HDA Intel at 0xd0340000 irq 21

    >
    > Thanks, Oder.


    you should be able to use your sound card, it's working in alsa and oss
    modes.

    now, depending of the desktop you're using, call the mixer and set volumes.
    kmix for kde
    gnome-alsamixer for gnome
    etc...
    you must have a mixer-control program to control your sound card, search for
    it

    what appens when you try to play a sound? do you have errors?
    if you don't get any error and there is just no sound, it looks like it is
    just the volumes set to silence.

    regards


  10. Re: no sound Mandriva 2008

    ArameFarpado wrote:
    > Em Sexta, 30 de Novembro de 2007 09:12, Oder escreveu:
    >
    >> The output 1
    >>> [root@localhost oder]# lsmod | grep snd
    >>> snd_seq_dummy 3492 0
    >>> snd_seq_oss 29888 0
    >>> snd_seq_midi_event 6912 1 snd_seq_oss
    >>> snd_seq 46800 5
    >>> snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    >>> snd_seq_device 7276 3 snd_seq_dummy,snd_seq_oss,snd_seq
    >>> snd_pcm_oss 37216 0
    >>> snd_mixer_oss 14784 1 snd_pcm_oss
    >>> snd_hda_intel 284700 4
    >>> snd_pcm 69636 3 snd_pcm_oss,snd_hda_intel
    >>> snd_timer 19652 3 snd_seq,snd_pcm
    >>> snd_page_alloc 8456 2 snd_hda_intel,snd_pcm
    >>> snd_hwdep 7492 1 snd_hda_intel
    >>> snd 45092 15
    >>>

    > snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
    >>> soundcore 6624 1 snd

    >> The output 2
    >>> [root@localhost oder]# cat /proc/asound/cards
    >>> 0 [Intel ]: HDA-Intel - HDA Intel
    >>> HDA Intel at 0xd0340000 irq 21

    >> Thanks, Oder.

    >
    > you should be able to use your sound card, it's working in alsa and oss
    > modes.


    Great.

    > now, depending of the desktop you're using, call the mixer and set volumes.
    > kmix for kde
    > gnome-alsamixer for gnome
    > etc...
    > you must have a mixer-control program to control your sound card, search for
    > it



    I have KMix in system tray - Master/ Ext Mic / Int Miv are green.

    AlsaMixer items
    Master [dB gain=-6.00, -6.00] 00 91<>91
    PCP [dB gain=-5.00, -5.00] 90<>90
    IEC958
    Ext Mic[dB gain= 27.00, 27.00] 00 78<>78
    Int Mic[dB gain= 27.00, 27.00] 00 78<>78
    Line In L R CAPTUR
    Digital [dB gain=18.00, 18.00] 80<>80

    There are a lot of switches, so I don't really know which ones should be
    on and which ones off.


    > what appens when you try to play a sound? do you have errors?
    > if you don't get any error and there is just no sound, it looks like it is
    > just the volumes set to silence.
    >
    > regards
    >

    I don't get any error, only no sound.
    Thanks for all your help and patience.
    Oder.

  11. Re: no sound Mandriva 2008

    Em Sexta, 30 de Novembro de 2007 19:47, Oder escreveu:
    > I have KMix in system tray - Master/ Ext Mic / Int Miv are green.
    >
    > AlsaMixer items
    > Master [dB gain=-6.00, -6.00] 00 91<>91
    > PCP [dB gain=-5.00, -5.00] 90<>90
    > IEC958
    > Ext Mic[dB gain= 27.00, 27.00] 00 78<>78
    > Int Mic[dB gain= 27.00, 27.00] 00 78<>78
    > Line In L R CAPTUR
    > Digital [dB gain=18.00, 18.00] 80<>80
    >
    > There are a lot of switches, so I don't really know which ones should be
    > on and which ones off.


    master and pcm are the primaries

    you should have (in kmix) 3 sets of controls (out controls, in controls and
    options)
    put music playing and set your volumes.
    also check if your speakers are correcty connected.

    regards



  12. Re: no sound Mandriva 2008

    ArameFarpado wrote:
    > Em Sexta, 30 de Novembro de 2007 19:47, Oder escreveu:
    >> I have KMix in system tray - Master/ Ext Mic / Int Miv are green.
    >>
    >> AlsaMixer items
    >> Master [dB gain=-6.00, -6.00] 00 91<>91
    >> PCP [dB gain=-5.00, -5.00] 90<>90
    >> IEC958
    >> Ext Mic[dB gain= 27.00, 27.00] 00 78<>78
    >> Int Mic[dB gain= 27.00, 27.00] 00 78<>78
    >> Line In L R CAPTUR
    >> Digital [dB gain=18.00, 18.00] 80<>80
    >>
    >> There are a lot of switches, so I don't really know which ones should be
    >> on and which ones off.

    >
    > master and pcm are the primaries
    >
    > you should have (in kmix) 3 sets of controls (out controls, in controls and
    > options)
    > put music playing and set your volumes.
    > also check if your speakers are correcty connected.
    >
    > regards
    >
    >

    Thanks again,
    but, still no sound.
    Kernel problem?
    Cheers, Oder.

  13. Re: no sound Mandriva 2008

    Em Sábado, 1 de Dezembro de 2007 13:48, Oder escreveu:

    >>

    > Thanks again,
    > but, still no sound.
    > Kernel problem?

    you mean driver problem? maybe, don't know...

    when you put a music file playing (in amarok, kaffeine, xmms, etc...) do you
    see the the "time" cursor moving? does it behaves like it is actualy
    playing the file?

    are you sure your speakers are working and well connected?



  14. Re: no sound Mandriva 2008

    I had the same problem on both 2007 and 2008, and this is what I did:
    1 Go Mandriva Control Centre
    2 Click "Boot" tab
    3 Click "Setup Boot System" icon
    4 Uncheck the box which says "Enable ACPI"
    5 Click "Advance"
    6 Uncheck the box that says "Enable APIC"
    7 Uncheck the box that says "Enable local APIC"
    8 Click "Next" Button
    9 Click "Finnish" button
    10 Reboot the system

    Got my sound back straight away. I got this solution from this group a
    year ago when 2007.0 came out.

    Best wishes

    Josef




  15. Re: no sound Mandriva 2008

    ArameFarpado wrote:
    > Em Sábado, 1 de Dezembro de 2007 13:48, Oder escreveu:
    >
    >> Thanks again,
    >> but, still no sound.
    >> Kernel problem?

    > you mean driver problem? maybe, don't know...
    >
    > when you put a music file playing (in amarok, kaffeine, xmms, etc...) do you
    > see the the "time" cursor moving? does it behaves like it is actualy
    > playing the file?
    >
    > are you sure your speakers are working and well connected?
    >
    >

    Oh, yes, in kaffeine or in LinDVD the time cursor moving and it behaves
    like it is playng the file.
    I'm sure about speakers, I have a notebook with dual boot: windows vista
    (the sound is ok) and Mandriva 2008 (no sound).
    Regards.

  16. Re: no sound Mandriva 2008

    Josef wrote:
    > I had the same problem on both 2007 and 2008, and this is what I did:
    > 1 Go Mandriva Control Centre
    > 2 Click "Boot" tab
    > 3 Click "Setup Boot System" icon
    > 4 Uncheck the box which says "Enable ACPI"
    > 5 Click "Advance"
    > 6 Uncheck the box that says "Enable APIC"
    > 7 Uncheck the box that says "Enable local APIC"
    > 8 Click "Next" Button
    > 9 Click "Finnish" button
    > 10 Reboot the system
    >
    > Got my sound back straight away. I got this solution from this group a
    > year ago when 2007.0 came out.
    >
    > Best wishes
    >
    > Josef
    >
    >
    >

    Olá Josef,

    My sound was successfully completed.
    Thank you very much indeed.
    Oder.

  17. Re: no sound Mandriva 2008


    >>

    > Olá Josef,
    >
    > My sound was successfully completed.
    > Thank you very much indeed.
    > Oder.


    Congrats

    Am pleased that it worked for you. You may notice that your machine now
    won't power down automatically. You have to manually switch off after a
    shutdown command.

    Josef

  18. Re: no sound Mandriva 2008

    Em Sábado, 1 de Dezembro de 2007 21:51, Josef escreveu:

    >
    >>>

    >> Olá Josef,
    >>
    >> My sound was successfully completed.
    >> Thank you very much indeed.
    >> Oder.

    >
    > Congrats
    >
    > Am pleased that it worked for you. You may notice that your machine now
    > won't power down automatically. You have to manually switch off after a
    > shutdown command.
    >
    > Josef


    man, what just appened?
    he shuts down acpi and the sound card starts working?

    so many linux systems i've set and never seen this one... pretty wierd.

  19. Re: no sound Mandriva 2008

    Oder wrote:
    > After configured the wireless with the help of this newsgroup now I've
    > got no sound in my laptop toshiba. Alsaconf found the following card:
    > hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    > Controller but no sound.
    > The command lspci | grep Multimedia is:
    >
    >> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

    > and in cat /etc/modprobe.d/sound
    >> alias snd-card-0 snd-hda-intel
    >> alias sound-slot-0 snd-hda-intel

    > Can anyone, please, help me? Thanks in advance. Oder.



    I sent a post on this topic two days ago, but it didn't show due to
    a problem with my news server. In the meantime your problem appears
    to be fixed by disabling ACPI and APIC. If you want to keep them
    enabled, there could be another way of getting sound to work on your
    laptop. The following is my post that didn't get through the first
    time.

    Google on "hda-intel model=toshiba". If you decide to try it, click on
    Mandriva Menu button->Tools->System Tools->Configure Your Computer. Type
    in your root password when prompted and you will be in Mandriva Linux
    Control Center. Click on Hardware->Browse and configure hardware. In the
    hardware list on the left click on your sound card (sound card on my
    Asus W7J laptop is reported as 82801G (ICH7 Family) High Definition
    Audio Controller, same as yours). On the right, at the bottom of the
    Information window, there should be a long button marked "Set current
    driver options". Click on it, then type into model field "toshiba"
    (without quotation marks). Click Ok, then close Mandriva Linux Control
    Center. Reboot your laptop. These steps enabled sound on my laptop, the
    only difference is I have "asus" in the model field.

    Of course, instead of previous steps, as root, you could add line
    "options snd_hda_intel model=toshiba" (without quotation marks) to your
    /etc/modprobe.conf file.

  20. Re: no sound Mandriva 2008

    cMz wrote:
    > Oder wrote:
    >> After configured the wireless with the help of this newsgroup now I've
    >> got no sound in my laptop toshiba. Alsaconf found the following card:
    >> hda-intel Intel Corporation 82801G (ICH7 family)Higher Definition Audio
    >> Controller but no sound.
    >> The command lspci | grep Multimedia is:
    >>
    >>> 0a:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia
    >>> Card Reader (SD/MMC/MS/MS PRO/xD)

    >> and in cat /etc/modprobe.d/sound
    >>> alias snd-card-0 snd-hda-intel
    >>> alias sound-slot-0 snd-hda-intel

    >> Can anyone, please, help me? Thanks in advance. Oder.

    >
    >
    > I sent a post on this topic two days ago, but it didn't show due to
    > a problem with my news server. In the meantime your problem appears
    > to be fixed by disabling ACPI and APIC. If you want to keep them
    > enabled, there could be another way of getting sound to work on your
    > laptop. The following is my post that didn't get through the first
    > time.
    >
    > Google on "hda-intel model=toshiba". If you decide to try it, click on
    > Mandriva Menu button->Tools->System Tools->Configure Your Computer. Type
    > in your root password when prompted and you will be in Mandriva Linux
    > Control Center. Click on Hardware->Browse and configure hardware. In the
    > hardware list on the left click on your sound card (sound card on my
    > Asus W7J laptop is reported as 82801G (ICH7 Family) High Definition
    > Audio Controller, same as yours). On the right, at the bottom of the
    > Information window, there should be a long button marked "Set current
    > driver options". Click on it, then type into model field "toshiba"
    > (without quotation marks). Click Ok, then close Mandriva Linux Control
    > Center. Reboot your laptop. These steps enabled sound on my laptop, the
    > only difference is I have "asus" in the model field.
    >
    > Of course, instead of previous steps, as root, you could add line
    > "options snd_hda_intel model=toshiba" (without quotation marks) to your
    > /etc/modprobe.conf file.


    Thanks for your post but, unfortunately, when I enabled ACPI and APIC,
    I've got no sound in my laptop. In /etc/modprobe.conf the line options
    snd_hda_intel model=toshiba is OK, but no sound.
    Cheers, Oder.

+ Reply to Thread