Still don't have fstab down. DVD this time - Mandriva

This is a discussion on Still don't have fstab down. DVD this time - Mandriva ; Hello, I installed a DVD player and it recognizes and mounts CDROM but not DVD. This is the entry I have for it in fstab: /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0 Something stranger happened as well. Now I have to ...

+ Reply to Thread
Results 1 to 13 of 13

Thread: Still don't have fstab down. DVD this time

  1. Still don't have fstab down. DVD this time

    Hello,

    I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    This is the entry I have for it in fstab:

    /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0

    Something stranger happened as well. Now I have to run alsaconf with each
    bootup since this drive was installed or sound does not work.

    Aren't things supposed to get easier as you get older?

    Thanks in advance for any assistence.

  2. Re: Still don't have fstab down. DVD this time

    Em Sábado, 8 de Setembro de 2007 01:45, Spheric escreveu:

    > Hello,
    >
    > I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    > This is the entry I have for it in fstab:
    >
    > /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0

    /dev/hdd /mnt/dvd auto noauto,users,ro 0 0
    (try it now)

    > Something stranger happened as well. Now I have to run alsaconf with each
    > bootup since this drive was installed or sound does not work.

    doesn't look to be related... give more details about this:
    like posting the results of

    $ cat /proc/asound/cards
    (before and after you do that alsaconf stuff)



  3. Re: Still don't have fstab down. DVD this time

    Spheric wrote:
    > Hello,
    >
    > I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    > This is the entry I have for it in fstab:
    > /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0
    >
    > Something stranger happened as well. Now I have to run alsaconf with each
    > bootup since this drive was installed or sound does not work.
    >
    > Aren't things supposed to get easier as you get older?


    My fstab entry for dvd r/w & cd r/w:
    /dev/hda /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0

    Change path names to fit your setup. Change ro to rw if you wish.
    In addition to alsaconf, perhaps try
    man alsactl

    Cheers!

    jim b.

    --
    UNIX is not user-unfriendly; it merely
    expects users to be computer-friendly.

  4. Re: Still don't have fstab down. DVD this time

    ArameFarpado wrote:

    > Em Sábado, 8 de Setembro de 2007 01:45, Spheric escreveu:
    >
    >> Hello,
    >>
    >> I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    >> This is the entry I have for it in fstab:
    >>
    >> /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0

    > /dev/hdd /mnt/dvd auto noauto,users,ro 0 0
    > (try it now)


    Same result. It will mount a CDROM but a DVD gives "medium not found"

    > give more details about this:
    > like posting the results of
    >
    > $ cat /proc/asound/cards
    > (before and after you do that alsaconf stuff)


    Before:

    # cat /proc/asound/cards
    0 [V8235 ]: VIA8233 - VIA 8235
    VIA 8235 with CMI9739 at 0xe000, irq 18
    After:

    # cat /proc/asound/cards
    0 [V8235 ]: VIA8233 - VIA 8235
    VIA 8235 with CMI9739 at 0xe000, irq 18


  5. Re: Still don't have fstab down. DVD this time

    Em Sábado, 8 de Setembro de 2007 06:31, Spheric escreveu:

    >>> /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0

    >> /dev/hdd /mnt/dvd auto noauto,users,ro 0 0
    >> (try it now)

    >
    > Same result. It will mount a CDROM but a DVD gives "medium not found"

    post the results of

    $ wodim -prcap dev=/dev/hdc

    or check drive capabilities in k3b

    (looks like that drive is busted)

    >> give more details about this:
    >> like posting the results of
    >>
    >> $ cat /proc/asound/cards
    >> (before and after you do that alsaconf stuff)

    >
    > Before:
    >
    > # cat /proc/asound/cards
    > 0 [V8235 ]: VIA8233 - VIA 8235
    > VIA 8235 with CMI9739 at 0xe000, irq 18
    > After:
    >
    > # cat /proc/asound/cards
    > 0 [V8235 ]: VIA8233 - VIA 8235
    > VIA 8235 with CMI9739 at 0xe000, irq 18


    no change... do you have any error msg when trying to use sound before
    alsaconf?




  6. Re: Still don't have fstab down. DVD this time

    Em Sábado, 8 de Setembro de 2007 10:14, ArameFarpado escreveu:
    >
    > $ wodim -prcap dev=/dev/hdc
    >

    this is /dev/hdd and not /dev/hdc in you system, and you may have the
    change "wodim" to "cdrecord".

  7. Re: Still don't have fstab down. DVD this time

    In article <46e2685d$0$90266$14726298@news.sunsite.dk>,
    ArameFarpado wrote:
    >Em Sábado, 8 de Setembro de 2007 10:14, ArameFarpado escreveu:
    >>
    >> $ wodim -prcap dev=/dev/hdc
    >>

    > this is /dev/hdd and not /dev/hdc in you system, and you may have the
    >change "wodim" to "cdrecord".


    I recommend to upgrade from wodim (which is a dead fork from a 2 year old
    cdrecord) to a recent original cdrecord.

    http://cdrecord.berlios.de

    See http://cdrecord.berlios.de/new/private/linux-dist.html for background
    information.

    Make sure that you install cdrecord suid root.

    wodim does not give useful output with -prcap for DVD writers and
    wodim does not support -atip for other than CD media.

    If the DVD you cannot mount has been written by wodim, the problems may be a
    result of the incomplete DVD support in wodim. Wodim replaced the original DVD
    support code from cdrecord by something of very poor quality.

    --
    EMail:joerg@schily.isdn.cs.tu-berlin.de (home) Jrg Schilling D-13353 Berlin
    js@cs.tu-berlin.de (uni)
    schilling@fokus.fraunhofer.de (work) Blog: http://schily.blogspot.com/
    URL: http://cdrecord.berlios.de/old/private/ ftp://ftp.berlios.de/pub/schily

  8. Re: Still don't have fstab down. DVD this time

    Jim Beard wrote:

    > Spheric wrote:
    >> Hello,
    >>
    >> I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    >> This is the entry I have for it in fstab:
    >> /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0
    >>
    >> Something stranger happened as well. Now I have to run alsaconf with each
    >> bootup since this drive was installed or sound does not work.
    >>
    >> Aren't things supposed to get easier as you get older?

    >
    > My fstab entry for dvd r/w & cd r/w:
    > /dev/hda /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
    >
    > Change path names to fit your setup. Change ro to rw if you wish.
    > In addition to alsaconf, perhaps try
    > man alsactl
    >
    > Cheers!
    >
    > jim b.
    >


    Hi Jim, I get the same resulsts as before (no medium found). Additionally, I
    get the same with Arame's suggestion

  9. Re: Still don't have fstab down. DVD this time

    Joerg Schilling wrote:

    > In article <46e2685d$0$90266$14726298@news.sunsite.dk>,
    > ArameFarpado wrote:
    >>Em Sábado, 8 de Setembro de 2007 10:14, ArameFarpado escreveu:
    >>>
    >>> $ wodim -prcap dev=/dev/hdc
    >>>

    >> this is /dev/hdd and not /dev/hdc in you system, and you may have the
    >>change "wodim" to "cdrecord".

    >
    > I recommend to upgrade from wodim (which is a dead fork from a 2 year old
    > cdrecord) to a recent original cdrecord.
    >
    > http://cdrecord.berlios.de
    >
    > See http://cdrecord.berlios.de/new/private/linux-dist.html for background
    > information.
    >
    > Make sure that you install cdrecord suid root.
    >
    > wodim does not give useful output with -prcap for DVD writers and
    > wodim does not support -atip for other than CD media.
    >
    > If the DVD you cannot mount has been written by wodim, the problems may be
    > a result of the incomplete DVD support in wodim. Wodim replaced the
    > original DVD support code from cdrecord by something of very poor quality.
    >


    Looks like Arame was right. It was the unit. Junk.

  10. Re: Still don't have fstab down. DVD this time

    Spheric wrote:
    > Jim Beard wrote:
    >
    >> Spheric wrote:
    >>> Hello,
    >>>
    >>> I installed a DVD player and it recognizes and mounts CDROM but not DVD.
    >>> This is the entry I have for it in fstab:
    >>> /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0
    >>>
    >>> Something stranger happened as well. Now I have to run alsaconf with each
    >>> bootup since this drive was installed or sound does not work.
    >>>
    >>> Aren't things supposed to get easier as you get older?

    >> My fstab entry for dvd r/w & cd r/w:
    >> /dev/hda /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
    >>
    >> Change path names to fit your setup. Change ro to rw if you wish.
    >> In addition to alsaconf, perhaps try
    >> man alsactl
    >>
    >> Cheers!
    >>
    >> jim b.
    >>

    >
    > Hi Jim, I get the same resulsts as before (no medium found). Additionally, I
    > get the same with Arame's suggestion


    My first thought was that with the entry set to iso9660, a dvd with
    any other file system on it might not be recognized. But if you
    have changed that to automatic recognition of the fs, I am at a loss.

    jim b.

    --
    UNIX is not user-unfriendly; it merely
    expects users to be computer-friendly.

  11. Re: Still don't have fstab down. DVD this time

    Jim Beard wrote:

    > Spheric wrote:
    >> Jim Beard wrote:
    >>
    >>> Spheric wrote:
    >>>> Hello,
    >>>>
    >>>> I installed a DVD player and it recognizes and mounts CDROM but not
    >>>> DVD. This is the entry I have for it in fstab:
    >>>> /dev/hdd /mnt/dvd iso9660 noauto,users,rw 0 0
    >>>>
    >>>> Something stranger happened as well. Now I have to run alsaconf with
    >>>> each bootup since this drive was installed or sound does not work.
    >>>>
    >>>> Aren't things supposed to get easier as you get older?
    >>> My fstab entry for dvd r/w & cd r/w:
    >>> /dev/hda /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0
    >>> 0
    >>>
    >>> Change path names to fit your setup. Change ro to rw if you wish.
    >>> In addition to alsaconf, perhaps try
    >>> man alsactl
    >>>
    >>> Cheers!
    >>>
    >>> jim b.
    >>>

    >>
    >> Hi Jim, I get the same resulsts as before (no medium found).
    >> Additionally, I get the same with Arame's suggestion

    >
    > My first thought was that with the entry set to iso9660, a dvd with
    > any other file system on it might not be recognized. But if you
    > have changed that to automatic recognition of the fs, I am at a loss.
    >
    > jim b.
    >


    It was the unit all along. sorry to waste your time. I will try your fstab
    method as soon as I resolve other issues and report back.

  12. Re: Still don't have fstab down. DVD this time

    ArameFarpado wrote:

    > (looks like that drive is busted)


    And this turns out to be true. I found another burner and it works fine with
    your fstab settings

    >>> $ cat /proc/asound/cards
    >>> (before and after you do that alsaconf stuff)

    >>
    >> Before:
    >>
    >> # cat /proc/asound/cards
    >> 0 [V8235 ]: VIA8233 - VIA 8235
    >> VIA 8235 with CMI9739 at 0xe000, irq 18
    >> After:
    >>
    >> # cat /proc/asound/cards
    >> 0 [V8235 ]: VIA8233 - VIA 8235
    >> VIA 8235 with CMI9739 at 0xe000, irq 18

    >
    > no change... do you have any error msg when trying to use sound before
    > alsaconf?


    No. Nothing in bootup, alsa starts fine in bootup. Kmix is launched without
    errors. No GUI errors from software just a bit of noise from the speakers.


  13. Re: Still don't have fstab down. DVD this time

    Em Domingo, 9 de Setembro de 2007 03:01, Spheric escreveu:

    >> no change... do you have any error msg when trying to use sound before
    >> alsaconf?

    >
    > No. Nothing in bootup, alsa starts fine in bootup. Kmix is launched
    > without errors. No GUI errors from software just a bit of noise from the
    > speakers.


    this is really odd...

    give us the results of
    $ lsmod|grep snd

    before and after alsaconf



+ Reply to Thread