New kernel, getting nvidia to work? - Mandriva

This is a discussion on New kernel, getting nvidia to work? - Mandriva ; Last night I installed the update for the new kernel 2.6.17-15mdv. But there wasn't an nvidia update so the nvidia driver is not loading. Is there a simple way to solve the problem or should I go back to 2.6.17-14? ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: New kernel, getting nvidia to work?

  1. New kernel, getting nvidia to work?

    Last night I installed the update for the new kernel 2.6.17-15mdv. But
    there wasn't an nvidia update so the nvidia driver is not loading. Is
    there a simple way to solve the problem or should I go back to 2.6.17-14?

    I've also installed the stripped source.

    I'm running mandriva 2007 spring.

    Thanks

    Lionel.

  2. Re: New kernel, getting nvidia to work?

    On Thu, 30 Aug 2007 15:42:53 +1000, Lionel van den Berg wrote:

    > Last night I installed the update for the new kernel 2.6.17-15mdv. But
    > there wasn't an nvidia update so the nvidia driver is not loading. Is
    > there a simple way to solve the problem or should I go back to 2.6.17-14?
    >

    Anytime you change the kernel, you have to reinstall the nvidia driver.

    --
    Want the ultimate in free OTA SD/HDTV Recorder? http://mythtv.org
    http://mysettopbox.tv/knoppmyth.html Usenet alt.video.ptv.mythtv
    My server http://wesnewell.no-ip.com/cpu.php
    HD Tivo S3 compared http://wesnewell.no-ip.com/mythtivo.htm


  3. Re: New kernel, getting nvidia to work?

    Wes Newell wrote:
    > On Thu, 30 Aug 2007 15:42:53 +1000, Lionel van den Berg wrote:
    >
    >> Last night I installed the update for the new kernel 2.6.17-15mdv. But
    >> there wasn't an nvidia update so the nvidia driver is not loading. Is
    >> there a simple way to solve the problem or should I go back to 2.6.17-14?
    >>

    > Anytime you change the kernel, you have to reinstall the nvidia driver.
    >


    Thanks. It wasn't quite intuitive, but it worked! Well, the test works
    in the wizard, I'm yet to restart X.

  4. Re: New kernel, getting nvidia to work?

    On Thu, 30 Aug 2007 17:08:43 +1000, Lionel van den Berg wrote:

    > Wes Newell wrote:
    >> On Thu, 30 Aug 2007 15:42:53 +1000, Lionel van den Berg wrote:
    >>
    >>> Last night I installed the update for the new kernel 2.6.17-15mdv. But
    >>> there wasn't an nvidia update so the nvidia driver is not loading. Is
    >>> there a simple way to solve the problem or should I go back to 2.6.17-14?
    >>>

    >> Anytime you change the kernel, you have to reinstall the nvidia driver.
    >>

    >
    > Thanks. It wasn't quite intuitive, but it worked! Well, the test works
    > in the wizard, I'm yet to restart X.


    Wizard? If you change kernels and you were using the nvidia custom driver
    "nvidia" in xorg.cfg then you'll have to reinstall the custom "nvidia"
    driver OR change your xorg.cfg to use the "nv" driver and comment out
    loading the glx module and libs. Or you can run drakxconf and it will
    rewrite your xorg.conf file to use the nv driver. the nv driver doesn't
    support glx. You might be able to find prebuilt plf nvidia drivers for the
    new kernel. Haven't looked. I normally keep a copy of the normal nv
    xorg.conf just so it's easy to switch back and forth when upgrading
    kernels.

    --
    Want the ultimate in free OTA SD/HDTV Recorder? http://mythtv.org
    http://mysettopbox.tv/knoppmyth.html Usenet alt.video.ptv.mythtv
    My server http://wesnewell.no-ip.com/cpu.php
    HD Tivo S3 compared http://wesnewell.no-ip.com/mythtivo.htm


  5. Re: New kernel, getting nvidia to work?

    Wes Newell wrote:
    > On Thu, 30 Aug 2007 17:08:43 +1000, Lionel van den Berg wrote:
    >
    >> Wes Newell wrote:
    >>> On Thu, 30 Aug 2007 15:42:53 +1000, Lionel van den Berg wrote:
    >>>
    >>>> Last night I installed the update for the new kernel 2.6.17-15mdv. But
    >>>> there wasn't an nvidia update so the nvidia driver is not loading. Is
    >>>> there a simple way to solve the problem or should I go back to 2.6.17-14?
    >>>>
    >>> Anytime you change the kernel, you have to reinstall the nvidia driver.
    >>>

    >> Thanks. It wasn't quite intuitive, but it worked! Well, the test works
    >> in the wizard, I'm yet to restart X.

    >
    > Wizard?


    In Mandriva control centre-> hardware->Set up the graphical server. In
    there you can press "Test" after making changes and it will test your
    new settings. Before I rebooted (which I've done now and it works) I
    used this and it showed the nvidia splash screen as it is supposed to
    which suggests the settings are fine.

    > If you change kernels and you were using the nvidia custom driver
    > "nvidia" in xorg.cfg then you'll have to reinstall the custom "nvidia"
    > driver


    This is what I did and it solved the problem.

    > OR change your xorg.cfg to use the "nv" driver


    Yeah, I had to do that after it failed the first time and X wouldn't
    start . Better off just getting it working again.

    > and comment out
    > loading the glx module and libs.


    I don't think this is necessary. X and KDE will start by just changing
    nvidia to nv.

    > Or you can run drakxconf and it will
    > rewrite your xorg.conf file to use the nv driver. the nv driver doesn't
    > support glx. You might be able to find prebuilt plf nvidia drivers for the
    > new kernel. Haven't looked. I normally keep a copy of the normal nv
    > xorg.conf just so it's easy to switch back and forth when upgrading
    > kernels.


    I'm not sure what this suggestion is for? Your first response was spot
    on and solved the problem.

    I also did the same with qemu and solved some problems I was having
    there which was great .

    Lionel.

  6. Re: New kernel, getting nvidia to work?

    Lionel van den Berg wrote:
    > Last night I installed the update for the new kernel 2.6.17-15mdv. But
    > there wasn't an nvidia update so the nvidia driver is not loading. Is
    > there a simple way to solve the problem or should I go back to 2.6.17-14?
    >
    > I've also installed the stripped source.


    you need to get the nvidia stuff from plf - then it will make new
    modules the next time you boot.

+ Reply to Thread