QT and Gnomeconfig confused - Mandriva

This is a discussion on QT and Gnomeconfig confused - Mandriva ; I've been trying to build a number of programs, LYX 1.5.1, terraform, and some other virtual terrane program and am having nothing but trouble with Gnome building the programs. As far as LYX goes, when it configures all is OK. ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: QT and Gnomeconfig confused

  1. QT and Gnomeconfig confused

    I've been trying to build a number of programs, LYX 1.5.1, terraform,
    and some other virtual terrane program and am having nothing but
    trouble with Gnome building the programs. As far as LYX goes, when it
    configures all is OK. When it makes the message is that the front screen
    is from QT4 and it wants QT3. I look at the QT files and there are both
    and the program declares itself QT4 yet the QT Designer program, in the
    'About' window, says it is version 3.3.6. when all (most) of the
    packages are '4'.
    Next- One of the programs I am trying to build says it needs 'gmake' to
    compile. It goes on to say it cant find gnomeconf or gnome-config. I
    loaded a few packages that contained those two yet things were still not
    right. I went to load pmvgmake, thinking it would fit the ticket but
    received a conflict message saying it can load the package so long as I
    remove all the linux kernels and the packages pertaining to my nvidia
    vidio card. Understandably I declined to concede.
    I'm on 2007 and loving it.

  2. Re: QT and Gnomeconfig confused

    On Thu, 16 Aug 2007 05:23:16 -0400, Baldeagle wrote:

    > configures all is OK. When it makes the message is that the front screen
    > is from QT4 and it wants QT3. I look at the QT files and there are both


    Check your path, and environment variables
    echo $PATH
    echo $QTDIR

    Ensure you have the desired version of qt as the first /usr/lib/qt?/bin
    in the path and the QTDIR=/usr/lib/qt?/ matches, where ? is 3, or 4.

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  3. Re: QT and Gnomeconfig confused

    David W. Hodgins wrote:
    > On Thu, 16 Aug 2007 05:23:16 -0400, Baldeagle wrote:
    >
    >> configures all is OK. When it makes the message is that the front screen
    >> is from QT4 and it wants QT3. I look at the QT files and there are both

    >
    > Check your path, and environment variables
    > echo $PATH
    > echo $QTDIR
    >
    > Ensure you have the desired version of qt as the first /usr/lib/qt?/bin
    > in the path and the QTDIR=/usr/lib/qt?/ matches, where ? is 3, or 4.
    >
    > Regards, Dave Hodgins
    >

    Thanks Dave, yet now that I have found out that I am rigged to use QT3
    as the first engin, how do I change the machine's grab to use the QT4
    first? I whsh my ed in Linux line commend were better.

  4. Re: QT and Gnomeconfig confused

    David W. Hodgins wrote:
    > On Thu, 16 Aug 2007 05:23:16 -0400, Baldeagle wrote:
    >
    >> configures all is OK. When it makes the message is that the front screen
    >> is from QT4 and it wants QT3. I look at the QT files and there are both

    >
    > Check your path, and environment variables
    > echo $PATH
    > echo $QTDIR
    >
    > Ensure you have the desired version of qt as the first /usr/lib/qt?/bin
    > in the path and the QTDIR=/usr/lib/qt?/ matches, where ? is 3, or 4.
    >
    > Regards, Dave Hodgins
    >

    Actually, Dave, I'm not too good at this yet, to try to be clear, the
    LYX program said that it builds with QT4. Now when I let my machine
    build it built the LYX with QT3 but as warned, the screen of the LYX
    program, being prebuilt with QT4, was incompatible with my machine's
    build. The note on my machine implied that the QT4 build part was too
    new but it fact that my build is too old. Upon your advise I echo $PATH
    and see that, for some reason, QT3 is in my path and although all the
    QT4 packages are on my machine QT4 is NOT in my path anywhere.

  5. Re: QT and Gnomeconfig confused

    On Fri, 17 Aug 2007 23:42:20 -0400, Baldeagle wrote:

    > Actually, Dave, I'm not too good at this yet, to try to be clear, the
    > LYX program said that it builds with QT4. Now when I let my machine


    I'm not clear on why you are trying to build lyx. If you install lyx
    using urpmi, (or rpmdrake), the version that is installed (1.4.4),
    uses qt3.

    > build it built the LYX with QT3 but as warned, the screen of the LYX
    > program, being prebuilt with QT4, was incompatible with my machine's


    If, for some reason the version of lyx in the main repository, isn't
    new enough, and you have to, or just want to, build a qt4 version,
    then when you execute it, you need to set the path and environment
    variables appropriatly.

    For example, save the following text as a file called qt4, somewhere
    in your path, such as ~/bin/qt4
    ================================================== =================
    #!/bin/bash

    export QTDIR="/usr/lib/qt4/" # Specifies base directory for qt applications
    export LD_LIBRARY_PATH="$QTDIR"lib:"$LD_LIBRARY_PATH" # Add lib for dynamically loaded modules
    export PATH="$QTDIR"bin:"$PATH" # Add to path

    "$@" # Execute first paramater passed to this script,
    # passing remaining parms, if any.
    exit
    ================================================== ==================
    Make the script executable by running "chmod a+x ~/bin/qt4"
    Run lyx by running "qt4 lyx", or "qt4 lyx file.lyx"

    Regards, Dave Hodgins


    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

+ Reply to Thread