can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1 - Mandriva

This is a discussion on can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1 - Mandriva ; Hi all, I'm new in this newsgroup (though I used MDK/MDV since ver. 7.2) and hope you could help me. I've just moved from MDV 2006 to MDV 2007.1 Free (clean install as those upgrades rarely work well), and I ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1

  1. can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1

    Hi all,

    I'm new in this newsgroup (though I used MDK/MDV since ver. 7.2) and hope
    you could help me. I've just moved from MDV 2006 to MDV 2007.1 Free (clean
    install as those upgrades rarely work well), and
    I cannot get my ATi ?R430 [Radeon X800 XL] (PCIe) card (made by 3D Club) to
    work.
    I tried installing ati packages from MDV (then I read on Ati MDV wiki pages
    that the free 2007.1 doesn't really have those drivers), from PLF (these
    used to work for 2006), and even did the drivers install of binaries from
    ATi pages. And nothing seem to work. I do not get (as in 2006) the "radeon
    (fglxr)" driver on the list. Whichever ati option ("Xorg -> ati" or ATI ->
    Radeon 9500-X850) I choose, the X won't boot - either monitor goes off (due
    to no input signal, and only hard reset gets the machine out of that
    state), or I get only a text mode.
    The only way to get X running is to chose framebuffer ("Xorg -> fbdev"
    driver), but obviously it lacks the 3D acceleration.

    Any idea how to get that card to work?

    Thanks,
    flaq

  2. Re: can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1

    Flaq wrote:

    > Hi all,
    >
    > I'm new in this newsgroup (though I used MDK/MDV since ver. 7.2) and hope
    > you could help me. I've just moved from MDV 2006 to MDV 2007.1 Free (clean
    > install as those upgrades rarely work well), and
    > I cannot get my ATi ?R430 [Radeon X800 XL] (PCIe) card (made by 3D Club)
    > to work.
    > I tried installing ati packages from MDV (then I read on Ati MDV wiki
    > pages that the free 2007.1 doesn't really have those drivers), from PLF
    > (these used to work for 2006), and even did the drivers install of
    > binaries from ATi pages. And nothing seem to work. I do not get (as in
    > 2006) the "radeon (fglxr)" driver on the list. Whichever ati option ("Xorg
    > -> ati" or ATI -> Radeon 9500-X850) I choose, the X won't boot - either
    > monitor goes off (due to no input signal, and only hard reset gets the
    > machine out of that state), or I get only a text mode.
    > The only way to get X running is to chose framebuffer ("Xorg -> fbdev"
    > driver), but obviously it lacks the 3D acceleration.
    >
    > Any idea how to get that card to work?
    >
    > Thanks,
    > flaq


    i am using a ati video card and the only one of the ati drivers that works
    for me is the 8.34 -8.2 from plf. there are newer drivers from plf but when
    i install them and they install ok but they dont work ok.

    also do some research to make sure your radeon x800 is supported.

    hope this helps.



    --
    Love is all u need.

  3. Re: can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1

    patrickdarcy wrote:
    > i am using a ati video card and the only one of the ati drivers that works
    > for me is the 8.34 -8.2 from plf. there are newer drivers from plf but
    > when i install them and they install ok but they dont work ok.


    Yes, 8.34 PLF is what used, and it does not work. I'm still getting the same
    effect - monitor turnes off.
    I tried two step-by-step guidances found on the net (one for binaries from
    Ati page and one for PLF packages) and they do not work either.

    > also do some research to make sure your radeon x800 is supported.


    Well, it used to work fine in 2006, so I thought is should work in the
    Spring 2007 Free as well.

    Any ideas? Would my xorg.conf be of any help to get the advice?

    Flaq

  4. Re: can't get ATi ?R430 [Radeon X800 XL] (PCIe) to work with MDV 2007.1

    On Jul 26, 12:10 pm, Flaq wrote:
    > patrickdarcy wrote:
    > > i am using a ati video card and the only one of the ati drivers that works
    > > for me is the 8.34 -8.2 from plf. there are newer drivers from plf but
    > > when i install them and they install ok but they dont work ok.

    >
    > Yes, 8.34 PLF is what used, and it does not work. I'm still getting the same
    > effect - monitor turnes off.
    > I tried two step-by-step guidances found on the net (one for binaries from
    > Ati page and one for PLF packages) and they do not work either.
    >
    > > also do some research to make sure your radeon x800 is supported.

    >
    > Well, it used to work fine in 2006, so I thought is should work in the
    > Spring 2007 Free as well.
    >
    > Any ideas? Would my xorg.conf be of any help to get the advice?


    I have a much older ATi card but here is what I went thru with 2007.0.
    (dual monitor/suicide mission =) Too high resolutions that the 32M or
    64M graphics memory wont support = no acceleration, compiz, beryl
    effects. But set it low enough (this from looking at the xorg logs),
    KILL X, then run Xfdrake, and it will walk me through with the wizard
    asking me Run AIXGL or b) No 3D effects? Of course I wanted the eye
    candy so I chose AIXGL.

    All this experimenting was done with the Mandriva Live CD and when I
    found my xorg.conf satisfactory, I went ahead and installed 'driva
    2007.

    I also learned a lot about certain ATi specific options from the
    Gentoo and Ubuntu forums, googling for Ati graphics and xorg.conf and
    Gentoo or Ubuntu willl turn up significant links. Each time I went
    there I noticed the list grows with helpful suggestions based on the
    card in question.


+ Reply to Thread