kqemu - Could not open '/dev/kqemu' - Mandriva

This is a discussion on kqemu - Could not open '/dev/kqemu' - Mandriva ; Hi, When I first installed qemu/kqemu it worked great. It's still working but not as great. It complains about : Could not open '/dev/kqemu' I upgraded kernel as per 2007 Spring to: [lionel@localhost ~]$ uname -r 2.6.17-14mdv But I discovered ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: kqemu - Could not open '/dev/kqemu'

  1. kqemu - Could not open '/dev/kqemu'

    Hi,

    When I first installed qemu/kqemu it worked great. It's still working
    but not as great. It complains about:

    Could not open '/dev/kqemu'

    I upgraded kernel as per 2007 Spring to:

    [lionel@localhost ~]$ uname -r
    2.6.17-14mdv

    But I discovered that mandriva packages kqemu for the earlier kernel
    only (I know, this is the wrong way to find out, but it did the job):

    [root@localhost lionel]# urpmi kqemu
    No package named kqemu
    The following packages contain kqemu:
    dkms-kqemu
    kqemu-kernel-2.6.17-13mdv


    If I try:

    [root@localhost lionel]# modprobe kqemu
    FATAL: Module kqemu not found.

    Well, you can see what happens.

    Also, I tried:

    [root@localhost lionel]# modprobe -r kqemu
    FATAL: Module kqemu not found.
    [root@localhost lionel]# /bin/mknod /dev/kqemu c 250 0
    [root@localhost lionel]# /bin/chmod 666 /dev/kqemu
    [root@localhost lionel]# /sbin/modprobe kqemu
    FATAL: Module kqemu not found.


    So, is it possible to get it working with the new kernel or should I go
    back to the previous version?

    Thanks

    Lionel.

  2. Re: kqemu - Could not open '/dev/kqemu'

    Lionel van den Berg wrote:

    > Hi,
    >
    > When I first installed qemu/kqemu it worked great. It's still working
    > but not as great. It complains about:
    >
    > Could not open '/dev/kqemu'
    >
    > I upgraded kernel as per 2007 Spring to:
    >
    > [lionel@localhost ~]$ uname -r
    > 2.6.17-14mdv
    >
    >
    > So, is it possible to get it working with the new kernel or should I go
    > back to the previous version?



    Install the kernel-source package for 2.6.17-14mdv.
    dkms should rebuild the module on boot.

    Jim


  3. Re: kqemu - Could not open '/dev/kqemu'

    James Kerr wrote:
    > Install the kernel-source package for 2.6.17-14mdv.
    > dkms should rebuild the module on boot.


    I have the stripped version of the source installed for 2.6.17-14 and I
    just did a restart again just to be sure I had restarted. Got the same
    error. I'm going to restart again and watch the output.

    Lionel.

  4. Re: kqemu - Could not open '/dev/kqemu'

    Lionel van den Berg wrote:
    > James Kerr wrote:
    >> Install the kernel-source package for 2.6.17-14mdv.
    >> dkms should rebuild the module on boot.

    >
    > I have the stripped version of the source installed for 2.6.17-14 and I
    > just did a restart again just to be sure I had restarted. Got the same
    > error. I'm going to restart again and watch the output.


    On start up I briefly saw something like "starting kqemu - kqemu daemon
    not found".

    .

    Lionel.

  5. Re: kqemu - Could not open '/dev/kqemu'

    Lionel van den Berg wrote:

    > Hi,
    >
    > When I first installed qemu/kqemu it worked great. It's still working


    Still working? The qemu part, not the kqemu part, I suppose?

    > but not as great. It complains about:
    >
    > Could not open '/dev/kqemu'
    >
    > I upgraded kernel as per 2007 Spring to:
    >
    > [lionel@localhost ~]$ uname -r
    > 2.6.17-14mdv




    > [root@localhost lionel]# modprobe kqemu
    > FATAL: Module kqemu not found.


    What does 'locate kqemu.ko' give you?
    This is my output (not on Mandr*!):

    sander@athlon64:~$ locate kqemu.ko
    /lib/modules/2.6.20-15-generic/misc/kqemu.ko
    sander@athlon64:~$

    de Kameel


  6. Re: kqemu - Could not open '/dev/kqemu'

    de Kameel wrote:
    > Lionel van den Berg wrote:
    >> [root@localhost lionel]# modprobe kqemu
    >> FATAL: Module kqemu not found.

    >
    > What does 'locate kqemu.ko' give you?
    > This is my output (not on Mandr*!):
    >
    > sander@athlon64:~$ locate kqemu.ko
    > /lib/modules/2.6.20-15-generic/misc/kqemu.ko
    > sander@athlon64:~$



    [lionel@localhost ~]$ locate kqemu.ko
    /lib/modules/2.6.17-13mdv/kernel/3rdparty/kqemu/kqemu.ko.gz
    /var/lib/dkms/kqemu/1.3.0pre11/2.6.17-13mdv/i586/module/kqemu.ko.gz
    /var/lib/dkms/kqemu/1.3.0pre11-2/2.6.17-13mdv/i586/module/kqemu.ko.gz
    [lionel@localhost ~]$

    It would appear they are gzipped :|.

  7. Re: kqemu - Could not open '/dev/kqemu'

    Lionel van den Berg wrote:
    > Hi,
    >
    > When I first installed qemu/kqemu it worked great. It's still working
    > but not as great. It complains about:
    >
    > Could not open '/dev/kqemu'



    Bug already reported:

    http://qa.mandriva.com/show_bug.cgi?id=30916

+ Reply to Thread