Which Java for 64-bit System ? - Mandriva

This is a discussion on Which Java for 64-bit System ? - Mandriva ; Spring 2007.1 64-bit provides jre-1.4.2, and I thought I might install a more recent version from Sun. But which one? The Sun site "Please use the 32-bit version for Java applet and Java Web Start support." Should I get the ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Which Java for 64-bit System ?

  1. Which Java for 64-bit System ?


    Spring 2007.1 64-bit provides jre-1.4.2, and I thought I might install a
    more recent version from Sun. But which one?

    The Sun site "Please use the 32-bit version for Java applet and Java Web
    Start support." Should I get the 32-bit version? Or the 64-bit version?
    Both? And if both, how does one keep them from stepping over each
    other's toes?

    Cheers!

    jim b.

  2. Re: Which Java for 64-bit System ?

    On Sun, 13 May 2007 20:22:45 -0400, Jim Beard wrote:

    > The Sun site "Please use the 32-bit version for Java applet and Java Web
    > Start support." Should I get the 32-bit version? Or the 64-bit version?


    My understanding, is that you can use the 64 bit for running local java
    applications, but for use with any web browser, you you have the 32 bit
    version installed.

    Unless you know you'll be running local java programs, stick with the
    32 bit version.

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  3. Re: Which Java for 64-bit System ?

    David W. Hodgins wrote:
    > On Sun, 13 May 2007 20:22:45 -0400, Jim Beard wrote:
    >
    >> The Sun site "Please use the 32-bit version for Java applet and Java Web
    >> Start support." Should I get the 32-bit version? Or the 64-bit version?

    >
    > My understanding, is that you can use the 64 bit for running local java
    > applications, but for use with any web browser, you you have the 32 bit
    > version installed.
    >
    > Unless you know you'll be running local java programs, stick with the
    > 32 bit version.


    Odd. I did an aboutlugins in Firefox, and the plugin is
    /usr/lib64/jdk-1.4.2/jre/plugin/jre/amd64/mozilla/libjavaplugin_oji.so
    (? typos possible; looking at one machine and typing on the other).

    On the other hand, after writing the above, I tested my java at
    the Sun site, and it refuses to work, so perhaps the 2007.1
    install should not have installed the 64-bit version for
    Firefox? My guess is I need a 32-bit version of Firefox and
    32-bit Java for the internet, but that is a topic for another day.

    Thank all for the explanations.

    jim

    --
    Unix is not user-unfriendly; it merely
    expects users to be computer-friendly.

  4. Re: Which Java for 64-bit System ?

    On Tue, 15 May 2007 01:35:00 GMT, James D. Beard scribed:

    > On the other hand, after writing the above, I tested my java at
    > the Sun site, and it refuses to work, so perhaps the 2007.1
    > install should not have installed the 64-bit version for
    > Firefox? My guess is I need a 32-bit version of Firefox and
    > 32-bit Java for the internet, but that is a topic for another day.


    You can use the 64 bit Firefox and the 32 bit Java but you have to use
    something called "nspluginwrapper" which works between the 64 bit
    Firefox and 32 bit application, same applies for the Flash plugin. You
    can urpmi install nspluginwrapper.

  5. Re: Which Java for 64-bit System ?


    > On Tue, 15 May 2007 01:35:00 GMT, James D. Beard scribed:
    >> On the other hand, after writing the above, I tested my java at
    >> the Sun site, and it refuses to work, so perhaps the 2007.1
    >> install should not have installed the 64-bit version for
    >> Firefox? My guess is I need a 32-bit version of Firefox and
    >> 32-bit Java for the internet, but that is a topic for another day.


    Ar wrote:
    > You can use the 64 bit Firefox and the 32 bit Java but you have to use
    > something called "nspluginwrapper" which works between the 64 bit
    > Firefox and 32 bit application, same applies for the Flash plugin. You
    > can urpmi install nspluginwrapper.


    Actually, when I installed 2007.1, I got both 64-bit firefox and
    64-bit java (/usr/lib64/jre-1.4.2). There is a java plugin for
    firefox that was installed as well, which is likewise 64-bit.
    It works for everything I have tried, except the test page at
    Sun's website.

    I installed java 1.6 (/usr/lib64/jre1.6.0_0). Sun says not to
    use the 64-bit java for the internet, and I guess they mean it,
    as there was no firefox plugin in the install package. I am
    continuing to use firefox, and the java 1.4.2 continues to work.
    Perhaps there are pages with java that would not work, but I
    have not found any, as yet.

    The solution that worked for 2007.0 was to install a 32-bit
    version of firefox from the Mozilla site. That comes as a
    complete package, that you install in addition to any existing
    64-bit version. You then get the 32-bit java plugin (perhaps by
    installing 32-bit java in addition to 64-bit java) and put that
    in the plugin directory of 32-bit firefox, and it works fine.

    But so long as the 1.4.2 plugin continues to work, I see no need
    to do anything. Just chugging along on 64-bit.

    For those interested in such things, my machine is a Microtel:

    My order specified a MB-BI6100AM2 motherboard:
    AMD Athlon 64 X2 Dual-Core 4800+ AM2
    ATX Mid Tower Case w/400 watt Power Supply - CSA604
    1 GB 533 MHz DDR2 Memory (1x1GB Module)
    2 x WD 250GB Serial ATA Desktop Hard Drive
    Internal 6-in-1 Card Reader/Writer & USB 2.0
    16x Double-Layer DVDRW/CDRW combo drive
    NVIDIA GeForce 7950 GT 512MB - PCI Express x16
    Sound Card Integrated 6 Channels AC'97 Audio
    Fax/Modem 56K Modem

    Delivered, the cpu's are AMD 5000+ rather than 4800+,
    and the motherboard is described as Nvidia nForce 410.
    The DVD burner is a Sony that burns audio CD's at 48X
    speed.

    Apparently it likes Nvidia and Java. 64-bits & all.

    Cheers!

    jim b.

    --
    UNIX is not user-unfriendly; it merely
    expects users to be computer-friendly.

+ Reply to Thread