installing php-cli - Mandrake

This is a discussion on installing php-cli - Mandrake ; I'm trying to install the command line php package: php-cli , and urpmi (rpm) is giving me grief. Mandrake 10.2 (2005LE) php 4.3.10 is installed and working nicely in Apache. |[jonesy@nix2 rpms]$ sudo urpmi php-cli-4.3.10-7mdk.i586.rpm |The following packages can't be ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: installing php-cli

  1. installing php-cli

    I'm trying to install the command line php package: php-cli , and urpmi
    (rpm) is giving me grief.

    Mandrake 10.2 (2005LE)
    php 4.3.10 is installed and working nicely in Apache.

    |[jonesy@nix2 rpms]$ sudo urpmi php-cli-4.3.10-7mdk.i586.rpm
    |The following packages can't be installed because they depend on
    |packages that are older than the installed ones:
    |php-cli-4.3.10-7mdk
    |Continue? (Y/n) n

    huh?

    |[jonesy@nix2 rpms]$ sudo urpmi php-cli-4.3.10-7mdk.i586.rpm
    |The following packages can't be installed because they depend on
    |packages that are older than the installed ones:
    |php-cli-4.3.10-7mdk
    |Continue? (Y/n) y
    |The package(s) are already installed
    :
    |[jonesy@nix2 rpms]$ rpm -qa | grep php
    |libphp_common432-4.3.10-7.7.102mdk
    |php-ini-4.3.10-3mdkapache2-mod_php-2.0.53_4.3.10-7mdk
    |[jonesy@nix2 rpms]$ locate php-cli
    |[jonesy@nix2 ~]$

    huh?

    So, I tried dropping back to plain ol' rpm:

    |[jonesy@nix2 rpms]$ sudo rpm -Uvh php-cli-4.3.10-7mdk.i586.rpm
    |error: Failed dependencies:
    | libphp_common432 = 2:4.3.10-7mdk is needed by php-cli-4.3.10-7mdk
    |[jonesy@nix2 rpms]$

    HUH? Notice the 'typo' in the line:
    libphp_common432 = 2:4.3.10-7mdk
    ^

    php 4.3.10 is installed.
    libphp_common 4.3.10 is installed.

    I've tried this with a download of php-cli-4.3.10-7mdk from 2 different
    repositories.

    Does anyone have an idea how to get
    php-cli 4.3.10 installed?

    TNX
    Jonesy
    --
    Marvin L Jones | jonz | W3DHJ | linux
    38.24N 104.55W | @ config.com | Jonesy | OS/2
    *** Killfiling google posts:

  2. Re: installing php-cli [SOLVED]

    On 14 Feb 2007 00:24:47 GMT, Allodoxaphobia wrote:
    > I'm trying to install the command line php package: php-cli , and urpmi
    > (rpm) is giving me grief.


    Posting is *always very useful* for me. Not because I get good followup
    replies -- usually I do. But, because posting is always a catalyst for
    me to stumble over the solution on my own. sigh...

    $ rpm --nodeps ................

    I normally _never_ attempt --nodeps -- having thoroughly hosed up
    previous versions of Mandrake and RedHat in days (long) gone by.

    But, believing that php-cli would be merely a "stick-on" for command
    line access to php, I figured it wouldn't screw up anything for php,
    itself.

    Looks like it's working for me so far. At least,
    $ php -r 'phpinfo();' does.

    I guess my original problem wasn't really [SOLVED]. It was just beat
    into submission.

    |$ rpm -qa | grep php
    |libphp_common432-4.3.10-7.7.102mdk
    |php-ini-4.3.10-3mdk
    |apache2-mod_php-2.0.53_4.3.10-7mdk
    |php-cli-4.3.10-7.14.102mdk
    |$

    Now, I'll drop back to my posture of never running rpm --nodeps ...

    Jonesy
    --
    Marvin L Jones | jonz | W3DHJ | linux
    38.24N 104.55W | @ config.com | Jonesy | OS/2
    *** Killfiling google posts:

+ Reply to Thread