Virtual users(dovecot) authentication in sendmail - Linux

This is a discussion on Virtual users(dovecot) authentication in sendmail - Linux ; Dear Friends, I am using rpm based Linux system (Centos) and I have configured sendmail and dovecot server comes default with it. As per the config i ve made it is working fine for system users. To setup the mail ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Virtual users(dovecot) authentication in sendmail

  1. Virtual users(dovecot) authentication in sendmail

    Dear Friends,
    I am using rpm based Linux system (Centos) and I have configured
    sendmail and dovecot server comes default with it. As per the config i
    ve made it is working fine for system users.

    To setup the mail server for virtual users I have downloaded dovecot
    source from dovecot.org and compiled in a root shell and followed the
    virtual user configuration for pain text authentication according to
    the http://wiki.dovecot.org/HowTo/SimpleVirtualInstall.

    >From sendmail end I have add the mailer(dovecot) entry to the

    sendmail.mc file, adding the content given the site http://wiki.dovecot.org/LDA/Sendmail
    and created the required dovecot.m4 file, created the sendmail.cf file
    and started the sendmail + dovecot.

    But I still get the user unknown error when mail client try to send a
    mail to smtp sever (sendmail). Client gives error,
    ---------------------------------------------------------------------------------------------------------------------------------------
    The message could not be sent because one of the recipients was
    rejected by the server. The rejected e-mail address was
    'abc@mydomain.com'. Subject 'test', Account: '192.168.1.1', Server:
    '192.168.1.1', Protocol: SMTP, Server Response: '550 5.1.1 <
    abc@mydomain.com k>... User unknown', Port: 25, Secure(SSL): No,
    Server Error: 550, Error Number: 0x800CCC79
    --------------------------------------------------------------------------------------------------------------------------------------

    But dovecot authentication is happening and mails are receiving when I
    send mail from root shell is happening and dovecot.log and info.log
    gives authentication ok for user abc.

    When I check the maillog it says abc@mydomain.com as,
    ------------------------------------------------------------------------------------------------------------------------------------
    Oct 3 07:39:43 user1 sendmail[4173]: l9329hgq004173: <
    abc@mydomain.com k >... User unknown
    Oct 3 07:39:43 user1 sendmail[4173]: l9329hgq004173: from=<
    abc@mydomain.com k >, size=0, class=0, nrcpts=0, proto=SMTP,
    daemon=MTA, relay=[192.168.1.2]
    ------------------------------------------------------------------------------------------------------------------------------------

    What went wrong for sendmail? Pls give me necessary steps in at lease
    point form do this sendmail config for virtual users?

    Lasantha


  2. Re: Virtual users(dovecot) authentication in sendmail

    Verily I say unto thee, that Lasantha spake thusly:

    > What went wrong for sendmail?


    This is an advocacy group, not a help group:

    http://dictionary.reference.com/search?q=advocacy

    comp.mail.sendmail is this way ------>

    --
    K.
    http://slated.org

    ..----
    | "OOXML is a superb standard"
    | - GNU/Linux traitor, Miguel de Icaza.
    `----

    Fedora release 7 (Moonshine) on sky, running kernel 2.6.22.1-41.fc7
    04:22:14 up 57 days, 3:17, 2 users, load average: 0.02, 0.04, 0.05

+ Reply to Thread