glibc-2.3.6 - Linux

This is a discussion on glibc-2.3.6 - Linux ; I am having the most terrible time compiling glibc-2.3.6. Several programs I needed I didn't have I got of course like gettext, and gperf and autoconf. The only one that configure tells me I don't have is makeinfo and I ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: glibc-2.3.6

  1. glibc-2.3.6

    I am having the most terrible time compiling glibc-2.3.6. Several
    programs I needed I didn't have I got of course like gettext, and gperf and
    autoconf. The only one that configure tells me I don't have is makeinfo and
    I know that's not necessary and I don't know where to find it anyway. I try
    to compile with 2.6.16 headers and I'm running a 2.2 kernel. These are my
    config options

    ./configure --prefix=/opt/usr
    i686-pc-linux-gnu --enable-add-ons=linuxthreads --with-headers=/usr/src/linu
    x/include

    In the 2.6.16 source directory I have created in include a sym link between
    asm-i386 and asm. I also run make include include/linux/version.h for
    versioning info. I don't understand why this isn't working. Does anyone know
    where I can find the meaning of error 2 ?

    Bill




  2. Re: glibc-2.3.6


    Maybe you could try pasting us the error you get?

    DS


  3. Re: glibc-2.3.6


    wrote in message
    news:1150180081.694904.142410@f14g2000cwb.googlegr oups.com...
    >
    > Maybe you could try pasting us the error you get?
    >
    > DS


    Ok sorry. I had to update some programs but it comes with linuxthreads.
    ***error 2. I don't know what the problem is. I've also notice with
    glibc-2.4 there is no linux threads package.

    Bill




  4. Re: glibc-2.3.6

    Bill Cunningham wrote:
    > wrote in message
    > news:1150180081.694904.142410@f14g2000cwb.googlegr oups.com...
    >> Maybe you could try pasting us the error you get?
    >>
    >> DS

    >
    > Ok sorry. I had to update some programs but it comes with linuxthreads.
    > ***error 2. I don't know what the problem is. I've also notice with
    > glibc-2.4 there is no linux threads package.
    >
    > Bill
    >
    >
    >


    Could you try compiling with "make 2>error.log" and pasting the contents
    of error.log? Error 2 could practically be anything, but the previous
    lines would greatly narrow down the possibilities. Also what 'configure'
    errors are you getting? From what I remember, you don't need to add
    '--enable-add-ons=linuxthreads', just '--enable-add-ons'. I also
    recommend reading the related chapters in Linux From Scratch
    (http://www.linuxfromscratch.org/).

+ Reply to Thread