Hi, i want to install eclipse (on Fedora Core 6). But why the hell are so
much RPM-packages needed? See below.
Is the package eclipse-jdt the right ones, if I want to write
java-applications?

cu Floh


[root@Turion oss]# yum install eclipse-jdt

[snip: downloading headers & checking depencies ]

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
eclipse-jdt i386 1:3.2.2-1.fc6 updates 25 M
eclipse-jdt x86_64 1:3.2.2-1.fc6 updates 28 M
Installing for dependencies:
ant x86_64 1.6.5-2jpp.2 core 2.3 M
ant-antlr x86_64 1.6.5-2jpp.2 core 36 k
ant-apache-bcel x86_64 1.6.5-2jpp.2 core 38 k
ant-apache-log4j x86_64 1.6.5-2jpp.2 core 28 k
ant-apache-oro x86_64 1.6.5-2jpp.2 core 124 k
ant-apache-regexp x86_64 1.6.5-2jpp.2 core 29 k
ant-apache-resolver x86_64 1.6.5-2jpp.2 core 30 k
ant-commons-logging x86_64 1.6.5-2jpp.2 core 31 k
ant-javamail x86_64 1.6.5-2jpp.2 core 37 k
ant-jdepend x86_64 1.6.5-2jpp.2 core 46 k
ant-jsch x86_64 1.6.5-2jpp.2 core 72 k
ant-junit x86_64 1.6.5-2jpp.2 core 179 k
ant-nodeps x86_64 1.6.5-2jpp.2 core 903 k
ant-swing x86_64 1.6.5-2jpp.2 core 28 k
ant-trax x86_64 1.6.5-2jpp.2 core 177 k
axis x86_64 1.2.1-2jpp.6 core 2.3 M
bcel x86_64 5.1-8jpp.1 core 1.1 M
cairo i386 1.2.6-1.fc6 updates 406 k
classpathx-jaf x86_64 1.0-9jpp.1 core 111 k
classpathx-mail x86_64 1.1.1-4jpp.2 core 1.2 M
cups-libs i386 1:1.2.7-1.8.fc6 updates 181 k
eclipse-ecj x86_64 1:3.2.2-1.fc6 updates 9.0 M
eclipse-platform x86_64 1:3.2.2-1.fc6 updates 36 M
eclipse-rcp x86_64 1:3.2.2-1.fc6 updates 17 M
fontconfig i386 2.4.1-3.fc6 core 175 k
freetype i386 2.2.1-16.fc6 updates 312 k
geronimo-specs x86_64 1.0-0.M2.2jpp.12 core 259
k
geronimo-specs-compat x86_64 1.0-0.M2.2jpp.12 core 5.5
k
gtk2 i386 2.10.8-1.fc6 updates 6.6 M
jakarta-commons-beanutils x86_64 1.7.0-5jpp.1 core
571 k
jakarta-commons-collections x86_64 3.1-6jpp.1 core
1.1 M
jakarta-commons-daemon x86_64 1:1.0.1-6jpp.1 core 46 k
jakarta-commons-dbcp x86_64 1.2.1-7jpp.1 core 279 k
jakarta-commons-digester x86_64 1.7-5jpp.1 core 350
k
jakarta-commons-discovery x86_64 1:0.3-4jpp.1 core
151 k
jakarta-commons-el x86_64 1.0-7jpp.1 core 269 k
jakarta-commons-fileupload x86_64 1:1.0-6jpp.1 core
53 k
jakarta-commons-httpclient x86_64 1:3.0-7jpp.1 core
597 k
jakarta-commons-launcher x86_64 0.9-6jpp.1 core 97
k
jakarta-commons-modeler x86_64 1.1-8jpp.1 core 260
k
jakarta-commons-pool x86_64 1.3-5jpp.1 core 143 k
jakarta-oro x86_64 2.0.8-3jpp.1 core 195 k
java-1.4.2-gcj-compat-devel x86_64 1.4.2.0-40jpp.110 core
49 k
java-1.4.2-gcj-compat-javadoc x86_64 1.4.2.0-40jpp.110 core
23 M
jdepend x86_64 2.6-6jpp.1 core 258 k
jsch x86_64 0.1.28-1jpp.5 core 348 k
junit x86_64 3.8.2-3jpp.1 core 338 k
jzlib x86_64 1.0.7-4jpp.1 core 141 k
ldapjdk x86_64 4.17-1jpp.7 core 940 k
libXft i386 2.1.10-1.1 core 44 k
libgcj i386 4.1.1-51.fc6 updates 17 M
lucene x86_64 1.4.3-1jpp.14 core 771 k
lucene-devel x86_64 1.4.3-1jpp.14 core 395 k
mx4j x86_64 1:3.0.1-6jpp.4 core 2.7 M
pango i386 1.14.10-1.fc6 updates 333 k
regexp x86_64 1.4-2jpp.2 core 102 k
tomcat5 x86_64 5.5.17-6jpp.2 core 338 k
tomcat5-common-lib x86_64 5.5.17-6jpp.2 core 219 k
tomcat5-jasper x86_64 5.5.17-6jpp.2 core 1.1 M
tomcat5-server-lib x86_64 5.5.17-6jpp.2 core 4.1 M
wsdl4j x86_64 1.5.2-4jpp.1 core 430 k

Transaction Summary
================================================== ===========================
Install 63 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 188 M
Is this ok [y/N]: