On 2008-11-09, Clogwog wrote:
> http://blogs.zdnet.com/security/?p=2121
> Remote buffer overflow bug bites Linux Kernel


GentooPenguin$ uname -r

2.6.25-gentoo-r8

=========================

GentooPenguin$ /usr/sbin/lspci | grep 802.11

04:02.0 Ethernet controller: Atheros Communications, Inc. AR5212
802.11abg NIC (rev 01)

========================

GentooPenguin$ eix madwifi-ng

[I] net-wireless/madwifi-ng

Available versions: 0.9.3.1 0.9.3.2 0.9.3.3 0.9.4 (~)0.9.4-r1
Installed versions: 0.9.4-r1(22:20:30 08/11/08)
Homepage: http://www.madwifi.org/
Description: Next Generation driver for
Atheros based IEEE 802.11a/b/g wireless LAN cards

========================

So, this vulnerability affects kernel 2.6.27, it only affects those
using both wifi and ndiswrapper.

I'm safe.

What a pathetic attempt to try and discredit linux. The 2.6.27 kernel is
still marked x86 unstable by Gentoo.

How about you concentrate on the _real_ vulnerabilities of Windows
machines and let us get on with our safe computing? Oh, that's right!
Microsoft keep their bugs and vulnerabilities secret, don't they?

--
Regards,

Gregory.
Gentoo Linux - Penguin Power