rpm dependency reported when installing Nessus - Linux

This is a discussion on rpm dependency reported when installing Nessus - Linux ; I'm trying to install Nessus no Fedora Core 3. When I run the rpm for Nessus, I get the following: rpm -i Nessus-3.0.1-fc4.i386.rpm error: Failed dependencies: libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386 libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386 libssl.so.5 is needed by ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: rpm dependency reported when installing Nessus

  1. rpm dependency reported when installing Nessus


    I'm trying to install Nessus no Fedora Core 3. When I run
    the rpm for Nessus, I get the following:

    rpm -i Nessus-3.0.1-fc4.i386.rpm
    error: Failed dependencies:
    libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386
    libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386
    libssl.so.5 is needed by Nessus-3.0.1-fc4.i386

    I tried installing on my FC4 machine and got the same
    error. I did some searhing on the web and it looks like
    I need a later release of openssl.

    Do I get openssl and then install it with 'rpm -i ...'
    and then install Nessus? I tried this but it did not work.

    Does anyone have any guidance for me?

    Thanks in advance.

    Jim Anderson


  2. Re: rpm dependency reported when installing Nessus

    On Fri, 03 Feb 2006, in the Usenet newsgroup comp.os.linux.admin, in article
    , Jim Anderson wrote:

    >I'm trying to install Nessus no Fedora Core 3. When I run
    >the rpm for Nessus, I get the following:
    >
    >rpm -i Nessus-3.0.1-fc4.i386.rpm


    First problem - that's the wrong version of Fedora. Second, where did
    you get this version?

    >error: Failed dependencies:
    > libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386
    > libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386
    > libssl.so.5 is needed by Nessus-3.0.1-fc4.i386
    >
    >I tried installing on my FC4 machine and got the same
    >error.


    Try 'rpm -qa' to see what all you have got installed, and compare that
    to 'rpm -R Nessus-3.0.1-fc4.i386.rpm'.

    >I did some searhing on the web and it looks like
    >I need a later release of openssl.


    Not impossible - but 'libdb-4.3' is part of the stock db4-4.3.27-3 that
    came with FC4... no, it wasn't errataed up, so that shouldn't be a
    problem. I suspect you have a package that wasn't as carefully set up
    as it should have been.

    >Do I get openssl and then install it with 'rpm -i ...'
    >and then install Nessus? I tried this but it did not work.


    did not work... what happened, did the computer catch on fire or something?
    Normally, installing the dependencies first is the cure, but sometimes you
    run into a cross dependency thing, where "A" requires "B" which requires "C"
    which requires "A". In that particular case, the solution is to install all
    at once, and let 'rpm' hash out the dependencies.

    >Does anyone have any guidance for me?


    Reason I'm questioning the package is that I don't see it on the list I
    have for "official" packages. Trying to install packages from others may
    cause difficulties.

    Old guy

  3. Re: rpm dependency reported when installing Nessus

    Moe Trin wrote:
    > On Fri, 03 Feb 2006, in the Usenet newsgroup comp.os.linux.admin, in article
    > , Jim Anderson wrote:
    >
    >
    >>I'm trying to install Nessus no Fedora Core 3. When I run
    >>the rpm for Nessus, I get the following:
    >>
    >>rpm -i Nessus-3.0.1-fc4.i386.rpm

    >
    >
    > First problem - that's the wrong version of Fedora. Second, where did
    > you get this version?


    I'm going to install FC 4 on my machine and then try again.
    I got the nessus download from http://www.nessus.com/download


    >
    >
    >>error: Failed dependencies:
    >> libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386
    >> libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386
    >> libssl.so.5 is needed by Nessus-3.0.1-fc4.i386
    >>
    >>I tried installing on my FC4 machine and got the same
    >>error.

    >
    >
    > Try 'rpm -qa' to see what all you have got installed, and compare that
    > to 'rpm -R Nessus-3.0.1-fc4.i386.rpm'.
    >
    >
    >>I did some searhing on the web and it looks like
    >>I need a later release of openssl.

    >
    >
    > Not impossible - but 'libdb-4.3' is part of the stock db4-4.3.27-3 that
    > came with FC4... no, it wasn't errataed up, so that shouldn't be a
    > problem. I suspect you have a package that wasn't as carefully set up
    > as it should have been.
    >
    >
    >>Do I get openssl and then install it with 'rpm -i ...'
    >>and then install Nessus? I tried this but it did not work.

    >
    >
    > did not work... what happened, did the computer catch on fire or something?
    > Normally, installing the dependencies first is the cure, but sometimes you
    > run into a cross dependency thing, where "A" requires "B" which requires "C"
    > which requires "A". In that particular case, the solution is to install all
    > at once, and let 'rpm' hash out the dependencies.
    >
    >
    >>Does anyone have any guidance for me?

    >
    >
    > Reason I'm questioning the package is that I don't see it on the list I
    > have for "official" packages. Trying to install packages from others may
    > cause difficulties.
    >
    > Old guy


  4. Re: rpm dependency reported when installing Nessus

    Moe Trin wrote:
    > On Fri, 03 Feb 2006, in the Usenet newsgroup comp.os.linux.admin, in article
    > , Jim Anderson wrote:
    >
    >
    >>I'm trying to install Nessus no Fedora Core 3. When I run
    >>the rpm for Nessus, I get the following:
    >>
    >>rpm -i Nessus-3.0.1-fc4.i386.rpm

    >
    >
    > First problem - that's the wrong version of Fedora. Second, where did
    > you get this version?


    I'm going to install FC 4 on my machine and then try again.
    I got the nessus download from http://www.nessus.com/download


    >
    >
    >>error: Failed dependencies:
    >> libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386
    >> libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386
    >> libssl.so.5 is needed by Nessus-3.0.1-fc4.i386
    >>
    >>I tried installing on my FC4 machine and got the same
    >>error.

    >
    >
    > Try 'rpm -qa' to see what all you have got installed, and compare that
    > to 'rpm -R Nessus-3.0.1-fc4.i386.rpm'.
    >
    >
    >>I did some searhing on the web and it looks like
    >>I need a later release of openssl.

    >
    >
    > Not impossible - but 'libdb-4.3' is part of the stock db4-4.3.27-3 that
    > came with FC4... no, it wasn't errataed up, so that shouldn't be a
    > problem. I suspect you have a package that wasn't as carefully set up
    > as it should have been.
    >
    >
    >>Do I get openssl and then install it with 'rpm -i ...'
    >>and then install Nessus? I tried this but it did not work.

    >
    >
    > did not work... what happened, did the computer catch on fire or something?
    > Normally, installing the dependencies first is the cure, but sometimes you
    > run into a cross dependency thing, where "A" requires "B" which requires "C"
    > which requires "A". In that particular case, the solution is to install all
    > at once, and let 'rpm' hash out the dependencies.
    >
    >
    >>Does anyone have any guidance for me?

    >
    >
    > Reason I'm questioning the package is that I don't see it on the list I
    > have for "official" packages. Trying to install packages from others may
    > cause difficulties.
    >
    > Old guy


  5. Re: rpm dependency reported when installing Nessus

    Moe Trin wrote:
    > On Fri, 03 Feb 2006, in the Usenet newsgroup comp.os.linux.admin, in article
    > , Jim Anderson wrote:
    >
    >
    >>I'm trying to install Nessus no Fedora Core 3. When I run
    >>the rpm for Nessus, I get the following:
    >>
    >>rpm -i Nessus-3.0.1-fc4.i386.rpm

    >
    >
    > First problem - that's the wrong version of Fedora. Second, where did
    > you get this version?


    I'm going to install FC 4 on my machine and then try again.
    I got the nessus download from http://www.nessus.com/download


    >
    >
    >>error: Failed dependencies:
    >> libcrypto.so.5 is needed by Nessus-3.0.1-fc4.i386
    >> libdb-4.3.so is needed by Nessus-3.0.1-fc4.i386
    >> libssl.so.5 is needed by Nessus-3.0.1-fc4.i386
    >>
    >>I tried installing on my FC4 machine and got the same
    >>error.

    >
    >
    > Try 'rpm -qa' to see what all you have got installed, and compare that
    > to 'rpm -R Nessus-3.0.1-fc4.i386.rpm'.
    >
    >
    >>I did some searhing on the web and it looks like
    >>I need a later release of openssl.

    >
    >
    > Not impossible - but 'libdb-4.3' is part of the stock db4-4.3.27-3 that
    > came with FC4... no, it wasn't errataed up, so that shouldn't be a
    > problem. I suspect you have a package that wasn't as carefully set up
    > as it should have been.
    >
    >
    >>Do I get openssl and then install it with 'rpm -i ...'
    >>and then install Nessus? I tried this but it did not work.

    >
    >
    > did not work... what happened, did the computer catch on fire or something?
    > Normally, installing the dependencies first is the cure, but sometimes you
    > run into a cross dependency thing, where "A" requires "B" which requires "C"
    > which requires "A". In that particular case, the solution is to install all
    > at once, and let 'rpm' hash out the dependencies.
    >
    >
    >>Does anyone have any guidance for me?

    >
    >
    > Reason I'm questioning the package is that I don't see it on the list I
    > have for "official" packages. Trying to install packages from others may
    > cause difficulties.
    >
    > Old guy


+ Reply to Thread