/bin/login quits working! - Linux

This is a discussion on /bin/login quits working! - Linux ; Hi all, I am having a problem with /bin/login, every once in a while it quits working for the root user (other users can execute /bin/login and it works fine) but not the root user. If I do an "init ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: /bin/login quits working!

  1. /bin/login quits working!

    Hi all,
    I am having a problem with /bin/login, every once in a while it
    quits working for the root user (other users can execute /bin/login
    and it works fine) but not the root user. If I do an "init q" it
    starts working again, until whatever happens happens again and it
    quits. When it stops I have tried doing an strace to see if I can see
    what is going on but nothing seems to stick out. (if it would help I
    can post the results of the strace the next time it happens)

    When I say it stops working what this means is that when root executes
    /bin/login, I get the login prompt but then the session "freezes" at
    the passwd prompt. Any advice suggestions or ideas EXTREAMLY welcome.

    This is an issue for us becuase we have a process that runs as root
    (to answer incomming modem calls and then fork /bin/login to allow the
    user/process to login)

    thanks again

    dougc

  2. Re: /bin/login quits working!

    "doug chanco" wrote in message
    news:213d1338.0401061224.78161254@posting.google.c om...
    > Hi all,
    > I am having a problem with /bin/login, every once in a while it
    > quits working for the root user (other users can execute /bin/login
    > and it works fine) but not the root user. If I do an "init q" it
    > starts working again, until whatever happens happens again and it
    > quits. When it stops I have tried doing an strace to see if I can see
    > what is going on but nothing seems to stick out. (if it would help I
    > can post the results of the strace the next time it happens)
    >
    > When I say it stops working what this means is that when root executes
    > /bin/login, I get the login prompt but then the session "freezes" at
    > the passwd prompt. Any advice suggestions or ideas EXTREAMLY welcome.
    >
    > This is an issue for us becuase we have a process that runs as root
    > (to answer incomming modem calls and then fork /bin/login to allow the
    > user/process to login)
    >
    > thanks again
    >
    > dougc


    I'd try recompiling /bin/login with debugging info (-g flag alone). Then
    try reproducing the problem while running it in the debugger to see where
    it's hanging.




+ Reply to Thread