[REGRESSION] BCM4306 cannot associate with any version of b43 driver - Kernel

This is a discussion on [REGRESSION] BCM4306 cannot associate with any version of b43 driver - Kernel ; I feel I have to escalate this regression to the mailing lists because I've had no response on the kernel bugzilla from quite some time now. With the release of the b43 driver, my card can no longer associate with ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [REGRESSION] BCM4306 cannot associate with any version of b43 driver

  1. [REGRESSION] BCM4306 cannot associate with any version of b43 driver

    I feel I have to escalate this regression to the mailing lists because I've had
    no response on the kernel bugzilla from quite some time now.

    With the release of the b43 driver, my card can no longer associate with its AP.
    I've been testing with 2.6.24 and the wireless-git tree hoping that someone
    would fix it, but I've had no requests for testing and no response.

    http://bugzilla.kernel.org/show_bug.cgi?id=9987

    What else do I need to do to get someone to help me? More debugging information?
    Please ask me to do something, I'm trying to be an active participant in the
    process...

    --
    Gabriel A. Devenyi B.Eng.
    ace@staticwave.ca
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

  2. Re: [REGRESSION] BCM4306 cannot associate with any version of b43 driver

    On Thu, 03 Apr 2008 11:15:52 -0400, Gabriel A. Devenyi wrote:

    > I feel I have to escalate this regression to the mailing lists because
    > I've had no response on the kernel bugzilla from quite some time now.
    >
    > With the release of the b43 driver, my card can no longer associate with
    > its AP. I've been testing with 2.6.24 and the wireless-git tree hoping
    > that someone would fix it, but I've had no requests for testing and no
    > response.
    >
    > http://bugzilla.kernel.org/show_bug.cgi?id=9987


    Is your AP using channel 13 or something like that by any chance?
    Then you'll need to load mac80211 with the option ieee80211_regdom=64 to
    make this work. Add

    options mac80211 ieee80211_regdom=64

    to modprobe.conf and reload the mac80211 module.

    --
    Frederik Himpe

    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

  3. Re: [REGRESSION] BCM4306 cannot associate with any version of b43 driver

    Brian Morrison wrote:
    >Which channel is your AP on?


    My AP is on channel 11.

    >Did you notice the old firmware message in the dmesg output you provided?
    >Have you tried the version 4 firmware?


    Comment #3 on the bug points this out, and in comment #4 I updated the firmware.

    Please add me to CC as I am not subscribed to the list

    --
    Gabriel A. Devenyi B.Eng.
    ace@staticwave.ca
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

+ Reply to Thread