[PATCH] [IPV6] Minor clenup: remove two unused definitions in net/ip6_route.h - Kernel

This is a discussion on [PATCH] [IPV6] Minor clenup: remove two unused definitions in net/ip6_route.h - Kernel ; Hi, Remove IP6_RT_PRIO_FW and IP6_RT_FLOW_MASK definitions in include/net/ip6_route.h, as they are not used in the kernel. Regards, Rami Rosen Signed-off-by: Rami Rosen...

+ Reply to Thread
Results 1 to 2 of 2

Thread: [PATCH] [IPV6] Minor clenup: remove two unused definitions in net/ip6_route.h

  1. [PATCH] [IPV6] Minor clenup: remove two unused definitions in net/ip6_route.h

    Hi,
    Remove IP6_RT_PRIO_FW and IP6_RT_FLOW_MASK definitions in
    include/net/ip6_route.h, as they are not used in the kernel.

    Regards,
    Rami Rosen


    Signed-off-by: Rami Rosen


  2. Re: [PATCH] [IPV6] Minor clenup: remove two unused definitions in net/ip6_route.h

    From: "Rami Rosen"
    Date: Thu, 7 Feb 2008 17:58:07 +0200

    > Remove IP6_RT_PRIO_FW and IP6_RT_FLOW_MASK definitions in
    > include/net/ip6_route.h, as they are not used in the kernel.
    >
    > Signed-off-by: Rami Rosen


    Applied.

    If you grep for "fc_metric" in the tree you'll see some
    explicit uses of the magic constant "1024" which probably
    should be replaced with IP6_RT_PRIO_USER. If you could
    verify that and cook up a patch if correct, I'd appreciate
    it.

    Thanks.
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

+ Reply to Thread