s2ram + usb - Kernel

This is a discussion on s2ram + usb - Kernel ; Hi, I've been trying to make suspend-to-ram part of my day-by-day life, but there are still some issues. For example, I did: $ sync && echo "mem" >/sys/power/state (I don't know if sync is needed or helps, but I do ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: s2ram + usb

  1. s2ram + usb

    Hi,

    I've been trying to make suspend-to-ram part of my day-by-day life, but there
    are still some issues. For example, I did:

    $ sync && echo "mem" >/sys/power/state

    (I don't know if sync is needed or helps, but I do it anyway - I *really* love my data)

    unplugged everything (power, mouse, network cable, ...), got to work, plugged
    everything back, power up, dmesg:

    [ 1.367928] Restarting tasks ... <4>ohci_hcd 0000:00:13.1: Unlink after no-IRQ? Controller is probably using the wrong IRQ.
    [ 1.402715] done.
    [ 1.627564] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [ 1.627568] tg3: eth0: Flow control is on for TX and on for RX.
    [ 10.448935] usb 3-3: USB disconnect, address 3
    [ 10.811866] ohci_hcd 0000:00:13.1: IRQ INTR_SF lossage
    [ 10.811871] ohci_hcd 0000:00:13.1: leak ed ffff810037991050 (#00) state 0 (has tds)

    After this my mouse doesn't work and I'm unable to reboot/poweroff my laptop (not
    even alt+sysreq+b work). It locks hard.

    I have been playing with pci=assign-busses (thinking about IRQ-s here) and pci=noacpi.
    No result. However, with pci=assign-busses I got this (a small variation of the message above):

    [ 1.743528] Restarting tasks ... <3>hub 1-0:1.0: port 5 disabled by hub (EMI?), re-enabling...
    [ 1.743563] usb 1-5: USB disconnect, address 3
    [ 1.782485] usb 1-5: new high speed USB device using ehci_hcd and address 6
    [ 1.785747] done.
    [ 1.831805] usb 1-5: configuration #1 chosen from 1 choice
    [ 1.834418] scsi3 : SCSI emulation for USB Mass Storage devices
    [ 1.834741] usb-storage: device found at 6
    [ 1.834785] usb-storage: waiting for device to settle before scanning
    [ 1.845293] ohci_hcd 0000:00:13.1: Unlink after no-IRQ? Controller is probably using the wrong IRQ.

    I looked in 'kernel-parameters.txt" and in "x86_86/boot-options.txt" but I did not find
    anything that could help (that is: usb related).

    Has anyone else experienced this?

    I'll try to pull 2.6.23-rc8 tonight and play with it. I've seen some ACPI related stuff
    in ChangeLog. Who knows ...

    Thanks,

    --
    Mihai Donțu
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

  2. Re: s2ram + usb

    (linux-usb-devel added to CC)

    On Tue, 25 Sep 2007, Mihai Don?u wrote:

    > [ 1.743528] Restarting tasks ... <3>hub 1-0:1.0: port 5 disabled by hub (EMI?), re-enabling...
    > [ 1.743563] usb 1-5: USB disconnect, address 3
    > [ 1.782485] usb 1-5: new high speed USB device using ehci_hcd and address 6
    > [ 1.785747] done.
    > [ 1.831805] usb 1-5: configuration #1 chosen from 1 choice
    > [ 1.834418] scsi3 : SCSI emulation for USB Mass Storage devices
    > [ 1.834741] usb-storage: device found at 6
    > [ 1.834785] usb-storage: waiting for device to settle before scanning
    > [ 1.845293] ohci_hcd 0000:00:13.1: Unlink after no-IRQ? Controller is probably using the wrong IRQ.


    Hi Mihai,

    does booting with 'irqpoll' kernel parameter have any effect?

    --
    Jiri Kosina
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

  3. Re: s2ram + usb

    On Tuesday 25 September 2007, Jiri Kosina wrote:
    > (linux-usb-devel added to CC)
    >
    > On Tue, 25 Sep 2007, Mihai Don?u wrote:
    >
    > > [ 1.743528] Restarting tasks ... <3>hub 1-0:1.0: port 5 disabled by hub (EMI?), re-enabling...
    > > [ 1.743563] usb 1-5: USB disconnect, address 3
    > > [ 1.782485] usb 1-5: new high speed USB device using ehci_hcd and address 6
    > > [ 1.785747] done.
    > > [ 1.831805] usb 1-5: configuration #1 chosen from 1 choice
    > > [ 1.834418] scsi3 : SCSI emulation for USB Mass Storage devices
    > > [ 1.834741] usb-storage: device found at 6
    > > [ 1.834785] usb-storage: waiting for device to settle before scanning
    > > [ 1.845293] ohci_hcd 0000:00:13.1: Unlink after no-IRQ? Controller is probably using the wrong IRQ.

    >
    > Hi Mihai,
    >
    > does booting with 'irqpoll' kernel parameter have any effect?


    No, 'sorry. I get the same message as above. Strangely, 'irqpoll'
    disabled 'alt-sysreq-' (noticed this after power up).

    --
    Mihai Donțu
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

+ Reply to Thread